Dodge Challenger Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
So I was in the market for the active exhaust delete kit, that makes the motor think it is still doing its job. However, I have been lead to believe that the 2019 and newer cars may not need such a device. Rather just removing the spring and reinstalling the motor after wiring the valve in the open position will be enough to eliminate the valve.

Can anyone confirm that this is correct? I guess I could try it and see if I get a CEL, but if I can avoid it I will.

Thanks in advance,
Will-
 

·
Registered
2016 R/T Scat Pack
Joined
·
1,222 Posts
I've been researching this topic quite a bit. Yes 2019+ you can just remove the spring. I have the fuse pulled on my 2016 for now but the CEL is on. I'll be ordering the Khaos delete kit soon.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
DO you know if the motor keeps spinning or does it stop? I'd hate to burn that motor out and end up with a CEL a year from now because it quite working.

Thanks!
 
  • Like
Reactions: gouge93

·
Registered
2019 Dodge Challenger RT
Joined
·
92 Posts
Pretty sure it's gonna throw a CEL. When I had my little diff incident at the track it bumped one of my active exhaust servos pretty hard and I think it messed up the spring. Rather than take it apart or replace the motor ($250 ea!), I went into HP Tuners and changed the active exhaust tables such that it would keep them set at 100% full time. It worked! No more CEL's and the exhaust sounds great full time.
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,340 Posts
Pretty sure it's gonna throw a CEL. When I had my little diff incident at the track it bumped one of my active exhaust servos pretty hard and I think it messed up the spring. Rather than take it apart or replace the motor ($250 ea!), I went into HP Tuners and changed the active exhaust tables such that it would keep them set at 100% full time. It worked! No more CEL's and the exhaust sounds great full time.
I thought so too but according to hemi leadsled on 2019s it will not. Not sure why 2017-2018 would be different...can't see a difference tune-wise or part number?
 

·
Registered
2020 HellRaisin 1320
Joined
·
249 Posts
DO you know if the motor keeps spinning or does it stop? I'd hate to burn that motor out and end up with a CEL a year from now because it quite working.
I'm wondering the same thing. Even if it doesn't throw up a CEL I don't want the actuators down there just spinning nonstop. I'm on the fence between just trying it out myself once my 1320 arrives or just getting the Khaos simulators. At least with the Khaos it keeps things clean without rigging flaps with random wire I can find in my garage and no worries about what the actuators are doing. And $150 isn't that much in the grand scheme of things. But its still $150 that I'd rather not throw away if I don't need to.

But so far I only know of hemi leadsled thats done it and when it comes to experiments, you can't publish results with just one single test.
 

·
Registered
2020 sps ordered 5/20/20
Joined
·
90 Posts
I'm still learning so...the reason some people get rid of the active exhaust is they want the full bore sound all the time, without the active exhaust electronics getting in the way, because when the car is underway the exhaust flap/valve actually moves with the throttle in unison...and the other step is to fully get rid of the moving apparatus down there also? If you do this, would you also do the resonator/mid muffler delete in addition like many have?
 

·
Registered
Joined
·
18 Posts
I'm still learning so...the reason some people get rid of the active exhaust is they want the full bore sound all the time, without the active exhaust electronics getting in the way, because when the car is underway the exhaust flap/valve actually moves with the throttle in unison...and the other step is to fully get rid of the moving apparatus down there also? If you do this, would you also do the resonator/mid muffler delete in addition like many have?
That's a good question I would like to know the answer to myself?

Also, I was playing around this weekend and pulled Fuse 36 to keep the Active Exhaust flap open. It sounds much better, but now have the CEL light too. So after trying it out I put back the fuse, and what do you know still seeing the CEL light. So wonder if I have to pull Fuse 31 to reset things, or should I reset my battery, by unplugging the battery and then back on again?
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
18,555 Posts
A CEL will go out after several drive cycles where the fault is not present

A Guy
 
  • Like
Reactions: BlueScatWB19

·
Registered
2019 Dodge Challenger 1320, high octane red, Race Stars and Mickey Thompson et rs, hurst shifter.
Joined
·
528 Posts
I'm wondering the same thing. Even if it doesn't throw up a CEL I don't want the actuators down there just spinning nonstop. I'm on the fence between just trying it out myself once my 1320 arrives or just getting the Khaos simulators. At least with the Khaos it keeps things clean without rigging flaps with random wire I can find in my garage and no worries about what the actuators are doing. And $150 isn't that much in the grand scheme of things. But its still $150 that I'd rather not throw away if I don't need to.

But so far I only know of hemi leadsled thats done it and when it comes to experiments, you can't publish results with just one single test.
Been over a year and still no codes. Also no spinning. You can hear a high pitch wine when they are plugged in and they turn. The way they work is they move and in a certain time period if something is wrong it will throw a code. Well mine still never popped a code
 
  • Like
Reactions: ChallyTatum

·
Registered
Joined
·
376 Posts
I thought those Khoas guys make the kit ?
Yeah the signal works great,
saturday
Best regards
parrotts
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,340 Posts
I thought those Khoas guys make the kit ?
Yeah the signal works great,
saturday
Best regards
parrotts
If you are responding to hemi leadsled...he is not running any AES delete kit. Apparently this procedure works for his 2019 challenger:
 

·
Registered
Joined
·
42 Posts
Discussion Starter #14
So I have yet to take the plunge, anyone done it trouble free? Thinking I may pull the springs on mine this afternoon.

Thanks,
Will-
 

·
Registered
Joined
·
5 Posts
I pulled the springs and wired the flaps open, 10 minute job and car sounds like it should all the time. No CEL so far on my 2019 T/A 392. Just did this a few days ago, so minimal miles and starts so far.
 

·
Registered
2020 sps ordered 5/20/20
Joined
·
90 Posts
Let us know how it goes, good luck!
 
1 - 17 of 17 Posts
Top