Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Vendor
Joined
·
5,670 Posts
Discussion Starter #1
I just received this from Todd at Aeroforce ...

"Just a note to let you know that the "issue" with some Challenger's experiencing battery drain with our gauge has been resolved. We had to add a delay before the gauge "pings" the bus when car is turned off to see if it's been started or not. When this time was too short a module in these cars was staying on and this was drawing too much current from the battery. We have tested this on our own Challenger for 6 weeks with no issues. Also, related to this, there is no need to use switched 12v to power the gauge on these cars any longer. Depending on what circuit people used, sometimes this power was noisy and would make the gauge do strange things. Since they can use the filtered OBD2 power now, this is no longer an issue either."

I asked what the fix is for those of us with gauges already and when I have an answer I'll post it here and help anyone out with this.

Lisa | Speedlogix
 

·
Registered
Joined
·
567 Posts
I wonder if they'll be allowing those of us who purchased ours last year to send them back for a software update? That would be great!
 

·
Premium Member
Joined
·
931 Posts
cant wait only had it less than 3 months and killed my battery the first day.
 

·
Vendor
Joined
·
5,670 Posts
Discussion Starter #4

·
Premium Member
Joined
·
931 Posts
well my battery died overnight im having a hard time believing its fixed! why dont they have a contact # this email crap sucks.
 
1 - 5 of 5 Posts
Top