Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
The prior owner of my car (2015 R/T with Super Track Pack) replaced the 5" radio with the 8.4" RA4 Nav radio. The car, since it came with the 5" radio, doesn't have the STP button although it is equipped with the STP.

Everything works great on the RA4 radio, I was able to update the navigation maps earlier this year and am running the 17.11.37 firmware. Everything works, including my travelink subscription through sirius/xm, yelp app, etc.

It does not have a connection to uconnect, which is good - for example, if I press the "register" or "store" button, it tells me the server is unavailable. So, I have no worries that the radio is registered with uconnect (as I understand, it can't be in order to make the performance pages work...)

My question is, has anyone used the OBD Genie to turn on the Performance Pages in a replacement radio similar to mine and had good success with it? I'm not interested in the Tazer, just to get that out of the way. :laugh2:
 

·
Registered
Joined
·
1 Posts
OBD Genie PPs for Dodge/Jeep RA4 Not Successful Yet

I bought the Genie 2 days ago. Installed it as per the directions but no PPs ever showed up. Did a reinstall and got an SRT splash screen only once and the performance app soft button would crash before the PPs even loaded. I called tech support and explained the issue. It is now packed up to be shipped back for troubleshooting. 2014 Jeep GC Limited.
 

·
Registered
Joined
·
185 Posts
Discussion Starter #3
Well. Mine will be here tomorrow. We will see.... not holding out much hope after reading all these posts of it not working. Ha ha.
 
1 - 3 of 3 Posts
Top