Dodge Challenger Forum banner

1 - 20 of 133 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
For the last few days, I have read a lot of threads on this and other forums regarding the installation of backup cameras on Challengers. Some refer to using the lockpic setup, some refer to dealer installations. But I saw a thread where a user who apparently works at a dealership was having trouble activating the camera on a 2012 Challenger. And I have seen no mention of trying it on a 2013. The website for the lockpic shows different year ranges for different cars but no mention of 2013 Challengers.

My 2013 has the U430N system. Does anyone have a definitive answer as to whether a backup camera can be made to work with the 2013 U430N? And if so, which system?
 

·
Registered
Joined
·
679 Posts
A factory engineer finally got mine working on my 2011. 2011 seems to be hit and miss. I don't think anyone has been successful with a 12 or 13. The process of getting the option code in the configuration seems to be flawed.
 

·
Premium Member
Joined
·
1,134 Posts
Luke, I understand that a factory option does not seem available for the 2012 & 2013 radios but was wondering if the aftermarket world would be the way to go for these users. I just installed an Nav-TV on my 2011 RBZ and from what I can see it should work on the newer radios. I would also guess the Lockpick units would work as well.

Quick check on the Nav-TV website shows the AllGIG XG-FT is compatible with the 2013 radios
http://navtv.com/product/175/allgig-xg-ft.html

From the Lockpick website...
"We have created the Lockpick to be universally applicable to
all models and vehicles compatible to the MYGIG radio from 2007-2011."
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I was not aware of the NavTV product. You are right, they do specifically mention the 2013 Challenger. Thanks for the link.
 

·
Registered
Joined
·
72 Posts
Lockpick on my 2012 730 doesn't work well. Camera works as advertised but the 12 has one less cable then the lockpick harness wants and so override functions never wrk and often the car is driving backward and won't navigate etc.

I really love the back up camera does the nav-tv av harness work the back up camera on the 730? Does it need the module too? Looks like you end up with an additional plug again the 12 730 doesn't want.
 

·
Banned
Joined
·
5,786 Posts
A factory engineer finally got mine working on my 2011. 2011 seems to be hit and miss. I don't think anyone has been successful with a 12 or 13. The process of getting the option code in the configuration seems to be flawed.
Hmm, that sucks, I was getting ready to order the lockpic!
 

·
Registered
Joined
·
330 Posts
I too would love to see this capability in 2013's. In lieu of that can any of you 2013 owners out there comment on the effectiveness of the latest version of the ParkSense rear park assist system?
 

·
Registered
Joined
·
221 Posts
I too would love to see this capability in 2013's. In lieu of that can any of you 2013 owners out there comment on the effectiveness of the latest version of the ParkSense rear park assist system?

The ParkSense seems to function properly. I didn’t realize that this car is like driving an armored HUMV until I got it home and was trying to back it into my garage. With the ParkSense I just take it nice and slow to allow it time to detect the objects and relay the info back to me through the EVIC. The EVIC displays which side of the bumper it detects objects on. I think it was a worthy and much needed addition to this car.
 
  • Like
Reactions: LarryR

·
Registered
Joined
·
20 Posts
I have recently purchased navtool back-up camera for my 2013 challenger, I was first offered the option at the dealership, but dealer quoted me sky high price. So I went online and did my research, found company called navtool, I was pretty amazed to learn that all of their products made in USA, so I purchased one camera interface plus i purchased alpine rear camera of ebay and installed it my all my self over a weekend. Works like a charm every time i put my vehicle in to reverse

P.S. site doesn't go up to 2013 but I can confirm it works perfectly on my 2013
 

·
Registered
Joined
·
171 Posts
Which model alpine camera did you purchase off ebay and where did you mount it?
Thanks,
Mark
 

·
Registered
Joined
·
171 Posts
Thanks. If you have a chance would like to see a picture.
 

·
Premium Member
Joined
·
1,848 Posts
I have recently purchased navtool back-up camera for my 2013 challenger, I was first offered the option at the dealership, but dealer quoted me sky high price. So I went online and did my research, found company called navtool, I was pretty amazed to learn that all of their products made in USA, so I purchased one camera interface plus i purchased alpine rear camera of ebay and installed it my all my self over a weekend. Works like a charm every time i put my vehicle in to reverse

P.S. site doesn't go up to 2013 but I can confirm it works perfectly on my 2013
How did you override the no dvd play while in motion?
 

·
Premium Member
Joined
·
58 Posts
I installed a backup camera in my 2012. I bought a used RBZ,lockpick and camera from OEM Auto parts took me a day to run all wiring and getting it working. Works great.
 

·
Premium Member
Joined
·
145 Posts
Cameras on 2013

I installed a v5 Lockpick along with 3 cameras. Used micro cams for the front and blind spot area. They all work good, easy to toggle between them using steering wheel's left control buttons. :icon_smile:
 

Attachments

·
Registered
Joined
·
63 Posts
Hopefully the 14's will get the 8.4 display and camera from the factory .


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
16 Posts
I have recently purchased navtool back-up camera for my 2013 challenger, I was first offered the option at the dealership, but dealer quoted me sky high price. So I went online and did my research, found company called navtool, I was pretty amazed to learn that all of their products made in USA, so I purchased one camera interface plus i purchased alpine rear camera of ebay and installed it my all my self over a weekend. Works like a charm every time i put my vehicle in to reverse

P.S. site doesn't go up to 2013 but I can confirm it works perfectly on my 2013
Thanks for the info. Where did you install the actual camera? I'm definitely looking for a solution,you can't see anything back there!
 
1 - 20 of 133 Posts
Top