Dodge Challenger Forum banner

21 - 31 of 31 Posts

·
Registered
2012
Joined
·
670 Posts
just cut the butterfly valve out and reinstall.
 

·
Registered
2015 Dodge Challenger Scat Pack
Joined
·
19 Posts
2015 Scat Pack. Just did a muffler delete. I'm happy with it. And I've received several compliments. Just took a 2 hour ride and did not drone me out. Added plus it was cheap to do. Still have the resonators on.
 

·
Premium Member
Joined
·
1,099 Posts
I'd contacted two different exhaust vendors and asked them to sell me the adaptive exhaust brackets they use on their systems. One declined and the other company ignored me. I wanted to see if it was worth the hassle to fabricate a delete bracket myself ended up pulling the fuse (rear 36).

Driving my A8 SRT I experienced no drone on the street or freeway with the fuse pulled. This however resulted in a CEL and prevented me from using remote start (bad news in the Arizona summer). The exhaust note was noticeable through all RPMs but not overbearing. MDS didn't sound horrible and didn't drone. After my experiment I wanted more so reinstalled the fuse and ordered a full replacement exhaust. Now if I can just get them to ship it...
Did pulling 36 do anything for you ? I had not started my car in 3 days, I first pulled fuse 36 in the trunk (active exhaust fuse). Thinking the default state of these are open, with the fuse pulled ...they should stay open. It had no effect, it did the loud start up, and within 45-60 seconds, got quite. (engine light did come on, resolved by a 5 minute battery disconnect).
Are these valves spring loaded to be open or closed then eclectically moved? For now, I don't care about codes thrown/engine light, I just want them stuck open for a while, so I can drive around and hear the difference.
Honestly I did not do a through test, when I removed fuse 36 and it got quite after 30 seconds, I shut it down, reset engine light and put the fuse back.
Maybe they did stay open and it only got quite cause it idled down, and if I'd of given it a chance and drove around an hour or so, I'd of seen a difference?
 

·
Registered
Joined
·
631 Posts
I'd say pull your fuse and CEL or not, drive it around for a few days. It certainly makes a difference on mine. Been driving mine for over a week now with the fuse out. I do have a CEL but I'm digging the exhaust tone to much to clear and reinstall the fuse.
 

·
Premium Member
2015 SRT
Joined
·
89 Posts
Did pulling 36 do anything for you?
It did improve the exhaust by keeping the valve open but causes a check engine light. I did eventually get the aftermarket exhaust but have since gone back to stock (you can read my horror story in the review section). All said and done I've reinstalled the fuse and am content with the factory exhaust at this point.
 

·
Premium Member
Joined
·
1,099 Posts
It did improve the exhaust by keeping the valve open but causes a check engine light. I did eventually get the aftermarket exhaust but have since gone back to stock (you can read my horror story in the review section). All said and done I've reinstalled the fuse and am content with the factory exhaust at this point.

I e been doing extensive testing last two hours...pulling 36 didn't seem to do anything. I then opens trunk lowered back seats and tested sports mode on/off....this does do a jump in volume, not sure it it's due to the valves though
 

·
Registered
Joined
·
160 Posts
I'm looking to do the same SLP on my SP! The fix isn't as clean and I'm not sure if a shop would understand how trick AES to make this system work so I'm a little reluctant to go this route just yet. I've contacted SLP but have gotten no response regarding a 2015+ system.
 

·
Registered
Joined
·
631 Posts
I bought AES simulators from fellow member Timmbo that will permanently lock that valves open. Won't be installing until this coming weekend. In the meantime, I'm on my second week with fuse 36 (trunk) pulled which has kept my AES valves open. The tone of my exhaust from idle thru cruise is nearly twice as loud with the fuse pulled (much like being in Track mode all the time) so I am quite confident the valves are open. I do have CEL but once I install the simulators I will reset with a battery cable pull and reinstall the fuse. I have over 500 miles with the fuse pulled and enjoying the exhaust tone. No measurable torque loss either.
 

·
Registered
Joined
·
160 Posts
Look for Timmbo's thread: Performance Modifications > Active Exhaust Valve Delete Simulators for 2015 Models
Thanks!
I just contacted him, asking for kind of an elaboration of how this will work exactly (so i can tell the shop :crying:). Please let us know how it goes!! I'm so excited for you hahah
 
21 - 31 of 31 Posts
Top