Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
2010 srt8 challenger 6 speed
Joined
·
55 Posts
Discussion Starter · #1 ·
so I just finished the mechanical part of the nitrous install and decided to drive it to work today. On the way I noticed a whistle when I give it gas but it only happens for a minute. Seems to be at an rpm and throttle position. I don't see any leaks i was wondering if its from the new throttle body position since I used a plate. It sounds like it has a turbo.
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,705 Posts
so I just finished the mechanical part of the nitrous install and decided to drive it to work today. On the way I noticed a whistle when I give it gas but it only happens for a minute. Seems to be at an rpm and throttle position. I don't see any leaks i was wondering if its from the new throttle body position since I used a plate. It sounds like it has a turbo.
I am not a nitrous guy, so...
Have you connected up the lines yet? Or just the plate/nozzles?
 

·
Registered
2010 srt8 challenger 6 speed
Joined
·
55 Posts
Discussion Starter · #3 ·
Everything is connected even the bottle. I just haven't wired it up yet and the bottle is still empty. I had one of the kids at work listen to it when I started it and he said it was coming from the CAI. Thats why I thought it was the TB position. When I'm sitting still and give it gas its not that noticeable which is probably why I didn't hear it when I started it last night. But this morning on the way to work I could really hear it. I had my tuner plugged in and everything looked normal. I got on it a little bit and it seems fine just that darn whistle
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy- GONE :-(
Joined
·
4,705 Posts
Everything is connected even the bottle. I just haven't wired it up yet and the bottle is still empty. I had one of the kids at work listen to it when I started it and he said it was coming from the CAI. Thats why I thought it was the TB position. When I'm sitting still and give it gas its not that noticeable which is probably why I didn't hear it when I started it last night. But this morning on the way to work I could really hear it. I had my tuner plugged in and everything looked normal. I got on it a little bit and it seems fine just that darn whistle
OK, gotcha, again, I'm not a nitrous guy, but what system did you install?
 

·
Registered
2010 srt8 challenger 6 speed
Joined
·
55 Posts
Discussion Starter · #6 ·
OK, gotcha, again, I'm not a nitrous guy, but what system did you install?
I used the nitrous outlet plate set up. Its a clean install for sure. It put the throttle body at an angle to make room for the solenoids. So the throttle plate isn't straight up and down its at a slite angle. With the whistle soumd coming from the CAI. That's all I can think it is. I guess I'm trying to find out if someone else has had that same issue
 

·
Registered
Joined
·
263 Posts
Check for a Vac leak....... With the car running, spray a little carb cleaner in the "area" where you were working in and see if the idle changes. Cracked hose, unconnected hose, failed gasket, etc. will cause a vac leak and whistle.

BTW! If you have access to a smoke machine that is even better.
 

·
Registered
2010 srt8 challenger 6 speed
Joined
·
55 Posts
Discussion Starter · #10 ·
Check for a Vac leak....... With the car running, spray a little carb cleaner in the "area" where you were working in and see if the idle changes. Cracked hose, unconnected hose, failed gasket, etc. will cause a vac leak and whistle.

BTW! If you have access to a smoke machine that is even better.
OK ill do that. I had that kid listen to it and he said it was coming from the CAI. But he is a kid😁 i might have a leak on the CAI piping but it all looks like it's good. I just hate to take it back apart. Damn I just got done lol. I wonder if I run it without the CAI and see if it still whistles. I know its risky because of sucking things in the throttle body. Looks like I need to do some investigating. I'll try the carb cleaner when I get home. Won't a vacuum leak give an engine code
 

·
Registered
2010 srt8 challenger 6 speed
Joined
·
55 Posts
Discussion Starter · #12 ·
A vac leak "MAY" throw a code on certain systems (like the EVAP/emission) but not on the intake.
Ok thanks. So I guess I'll be working on it again today😬 i probably do have a leak on the air intake side. I was hoping it was just the nitrous thing. Oh well the rest of the stuff for me to wire it all up comes today. Was hoping to work on that but now I have to find a whistle.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,696 Posts
Remove the CAI hose to the throttle body, if it continues, you have confirmed that 1/2 is ok, then are looking to see if it's just air flow noise, or something else. If it stops when CAI disconnected, do a "reinstall" on the whole CAI, see if it was just angle, air leak, etc.

A Guy
 

·
Registered
2010 srt8 challenger 6 speed
Joined
·
55 Posts
Discussion Starter · #14 ·
Remove the CAI hose to the throttle body, if it continues, you have confirmed that 1/2 is ok, then are looking to see if it's just air flow noise, or something else. If it stops when CAI disconnected, do a "reinstall" on the whole CAI, see if it was just angle, air leak, etc.

A Guy
Well I took the CAI off after I did the check with some carb cleaner as suggested which didn't seem to show a leak. I left the 90 on the throttle body and it still had a whistle. Then I loosened up the throttle body and the plate for the nitrous and did some tweaking cause when I put my finger on the throttle body it didn't seem to be a smooth fit. Once I got that all lined up and tightened back up I put the CAI back together and did some adjustment on it to make it more of a straight flow. I started the car and could hear just a little noise but didn't drive it....it was late when I got done and I was tired. But it did seem to quite it down. I'm going to maybe get it out today and see how it sounds. I talked to nitrous outlet and they said if everything is ok its probably air blowing across the jets in the plate. I think it is some kind of air flow thing. I'll just keep tweaking things and if I can't get rid of it looks like it will just sound like it has a turbo lol. I appreciate all the input and thoughts. I'll give updates especially if I find out exactly what it is. Thanks again everyone
 
1 - 15 of 15 Posts
Top