Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 20 of 23 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
OK so last year I put a Kenwood DNX9960 in my challenger.

Then I needed better speakers so I put in JL components in the doors and rear deck.

Then I need an AMP for more power

Then I needed some BUMP so another amp and a JL 10w7

SUB and 500/amp finished last weekend, Thanks go to my Brother Austin for doing the SUB box with the AMP rack and mounting it so nice.















 

·
Registered
Joined
·
1,659 Posts
Clean install.
 

·
Registered
Joined
·
191 Posts
Very clean. Nice work.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #6 ·
I just got the slash 300 and am going with JL's doors and deck also. How did you like it previous to adding the sub?
Just the JL components in the doors and rear deck with the 300/ amp sounded good but it didnt have enough bottom end.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
132 Posts
Discussion Starter · #10 ·
Was the 300 plenty of power to keep it clean at higher volumes?
Was and still is Sounds clean and LOUD. Alot of the quality has to do with the quality of the speakers tho too. JL makes some nice stuff.
 

·
Premium Member
Joined
·
860 Posts
did you buy the stereo from crutchfield?i have the boring res stereo in my 2010 rt.i was checking out some stereos and the kenwoods look pretty good.how much modification did you have to do to get the stereo to fit?
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #12 ·
Got the Kenwood local. Audio shop cut me a deal and I installed it my self. The install was easy took less than an hr. There was an older post on the interior forum that described in detail how to do the install. I had to remove two small plastic nubs from about 4 inches into the hole where the stock radio went. These nubs were kept the dbl din radio from sliding in all the way.
 

·
Registered
Joined
·
323 Posts
nice very clean. your brother does really good work. normally when i open one of these type posts i see a bare box with wires all over the place. great job.
 

·
Premium Member
Joined
·
860 Posts
when you installed your radio,did you hard wire to the different sensors?like the parking brake sensor,back up lamp and speed sensor.
 
1 - 20 of 23 Posts
Top