Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello

I recently had claim repair done on my front bumper and I have issues with the repair. I could use you guys' expert advise. The top part of the fascia is no longer flush with the hood. I was wondering if anyone might know what may be the issue? Is something missing? Clips may not be on correctly? I have attached some pictures to demonstrate what I mean. It seems to me that the top light covers look odd. They are flimsy and pull right off with a gentle pull. It seems to me they should be tight. It almost seems as if the parts that the shop installed may not be the correct parts for this car (2013 challenger RT blacktop).

Any help and advice appreciated. Thank you very much.
 

Attachments

·
Premium Member
2014 100th Annivesary R/T
Joined
·
517 Posts
Looks like an alignment issue to me, should be able to take it back to where you had the work done and have them fix the alignment of the fascia. Where it mounts to the fenders its slotted and should be able to adjust it to clean that up.

-Kenny
 

·
Premium Member
2016 Hellcat
Joined
·
182 Posts
The only bolts on the whole front is at the fenders, that area looks OK. Everything else is push pins and plastic rivets. There are no real adjustments. Mine was removed and took a few days of sitting in the sun to settle it back down. Cheapest front assembly I ever worked on.
 

Attachments

·
Premium Member
Joined
·
1,434 Posts
Take it back don't settle. They have to make it right.
 
1 - 7 of 7 Posts
Top