Dodge Challenger Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Made a few setup changes since i had the car at road atlanta, parts from mainly steve white motors and razors edge on car include sub frame connectors, strut braces front and rear, rear seat delete, hellcat front brakes and wheels, RE71r tires, progress sway bars, hawk dtc 70/60 pads. I had eibach lower springs with stock shocks at road atlanta and the car was slight sprung to stiff in the rear and did put down power very well on exit. Ive changed the suspension to pedders coilovers which feel dampened much better than the stock parts. The eibachs was sprung around 377/931, the betters with are 559/671. Im running the pedders at 26 clicks rear around 24 front, and i feel like the car could use a slightly stiffer rear spring as the car puts power down really well and turns in good but pushes a bit on exit. Sway bar fronts are full soft rear is full stiff, i could raise the rear of the car some as well which i may try before changing rear springs. My largest problem is i blew an axle boot on my third run session so i only got 2 20 mins sessions with the car at mid ohio, im pretty sure i could have shaved another 1-2 seconds off the car by the end of the day. Ive got a set of drive shaft shop rear axles to put in the car to see if there boots will hold up, as i also blew boots after the 3rd session at road atlanta, keep running the car and seized an axle. So far 2 track days 2 blown boots. Not sure if its from where the car is lowered or the boots just suck as ive seen multiple posts about boots leaking.


 
1 - 2 of 2 Posts
Top