Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I hope I'm putting this in the right place. I have searched this like crazy. I purchased my 09 challenger r/t two months ago and for the last month it has been in the shop. It has been the worst experience buying a car I have ever had. First off the dealer gave me a high mileage warranty which my car is not a high mileage car and should have given me their bumper to bumper warranty. The dealer said they would switch my warranty over to the correct one. The warranty company wouldn't pay for the computer since it has already had a claim filed on it with the wrong warranty. The dealer said they would pay for the computer themselves.

When I turn my radio up past seven the radio will cut out, all of the lights come on, on the dash (abs, airbag, battery everything), also the spedo and tach fuel gauge go to zero while driving down the road. So the dealer replaced the tipm module (computer I think) and it did not fix the problem they said it made it worse. So now I am waiting on the dealer to hear back from Chrysler on what else they think it could be! I just want my car back that I have wanted for so long. Any help would be awesome.
 

·
Registered
Joined
·
1,744 Posts
Sorry to hear about your luck! I am guessing you may need a entire wire harness that communicates from computer to radio and gauge cluster. That would be a mess.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Sorry to hear about your luck! I am guessing you may need a entire wire harness that communicates from computer to radio and gauge cluster. That would be a mess.
I wish I knew what it was. That sounds very possible because they said it the can bus b I think is what they called it wasn't communicating with the tipm module, replaced that and it is worse than it was before.
 

·
Registered
Joined
·
4,564 Posts
I would first have the dealership correct the warranty issue. Once that's done, I would take my car to a different dealership. :disgust:
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Could just be a ground problem ,,,I have seen a lot of tech's dive into the abyss without checking the basics ,,,
It was I got my car back today it ended up that another had replaced the window motor and sliced a wire and was shorting out on the door and ended up frying the computer so it was good that they replaced that. She's great now!
 

·
Registered
Joined
·
99 Posts
When I turn my radio up past seven the radio will cut out said:
I am having the same issue with my '12 Ram 1500. All the idiot lights come on, RPM/Speedo go to zero and back, chime starts ringing, wipers sweep ( sometimes several times ) and now the radio screen goes off and back on. Dealership SAID it was the tipm module and will be installed on Tuesday.. the only non-stock item is Lo Jack which was installed at that dealership and a MyGig( just plug n play ).
No other work has been done so I cant see how a wire can be cut or have a short.

We will see Tuesday
 

·
Registered
Joined
·
149 Posts
I am having the same issue with my '12 Ram 1500. All the idiot lights come on, RPM/Speedo go to zero and back, chime starts ringing, wipers sweep ( sometimes several times ) and now the radio screen goes off and back on. Dealership SAID it was the tipm module and will be installed on Tuesday.. the only non-stock item is Lo Jack which was installed at that dealership and a MyGig( just plug n play ).
No other work has been done so I cant see how a wire can be cut or have a short.

We will see Tuesday
You car has been worked on,,It was put together at the factory,,,,,Maybe on friday after a fatty and a 6 beer lunch,,Who knows :huh:
 
1 - 9 of 9 Posts
Top