Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
After install of headers on 2010 srt8 check engine light came on. This is a car I'm looking to buy it a 6speed. I currently have a auto 2010. Any ideas how to correct this problem? I don't know all mods installed on car as of right now but headers seems to have caused the problem so i was told.
:notallthere:
 

·
Registered
Joined
·
40 Posts
My check engine light came on after I installed my Mopar CAI. At first I thought I damaged the IAT sensor since it was such a PITA to fit in. I tried to remove fuse #2 for about a minute and that didn't seem to help. I ended up disconnecting the battery for about 10 minutes and that did the trick, light went away and she drove fine. I would suggest doing this, if it does not fix the issue you can do a trick with the key and see the engine codes (search forum and you will find it). Let us know what you find out, I want to get some new headers at some point too.
 

·
Registered
Joined
·
219 Posts
I am currently waiting for the arrival of my ARH with cats. Looking into this before ordering, all the hi flow cats seem to trip the engine light. The cats are larger in diameter and flow more exhaust, the rear o2 sensors pick up on this sensing the exaust is not the same or not treated as much. The correct fix is to have a shop tune the car with what is called a CMR tune. They can do that with a Diablo Sport Predator tuner, it will pass an emissions test & run strong. I have not heard of any of the "tricks" being used out there to really work. Shutting off the rear o2 sensors won't allow it to pass a test if you have to be tested.
 

·
Banned
Joined
·
7,566 Posts
This problem can't be "tuned" out. Most CMR tunes for LT headers shut off the rear O2 sensors and then you'll fail emissions most places.
 
1 - 4 of 4 Posts
Top