Dodge Challenger Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Anyone seen this before? Car will sit for a week or more. Jump in, fire it up, clock is off by an hour. Always an hour earlier than it should be. Plain Jane radio. I haven't found any "Time Zone" settings, so I don't really understand why it would be changing. If that was the case, you'd think it would change shortly after setting the correct time.
 

·
Super Moderator
Joined
·
15,601 Posts
Do you have "Use GPS" selected for time?
 

·
Registered
Joined
·
125 Posts
Discussion Starter #3
I honestly don't think I have seen that option, so I'll say no. I'll take another good look through the menu tomorrow. I don't have any options that would use GPS on the radio though.
 

·
Registered
2015 Dodge Challenger SRT
Joined
·
543 Posts
If you have NAV, then your radio can set the time according to your location.

If you have NAV ...... Do you live near a change in time zones? We have farmland on either side of the Illinois - Indiana state line and they're in different time zones. Drives my phone insane when I walk from one side of the house to the other and it switches from an Illinois cell tower to an Indiana cell tower.


If you don't have NAV, could you be inadvertently touching the time on the radio screen? Though .... I think you would also have to manually change the time after you touch the time. It's been a while since I didn't have NAV.
 

·
Registered
Joined
·
2,522 Posts
This has happened once around the time we went to DST. I set the correct time but noticed a day or so later the time was off an hour. Thought I forget to set the clock so set it again. Day or so later again noticed the time was off by an hour. All I could think of is to just set the clock once more. Since then it appears to be staying set.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #7
Checked for a GPS option. Nothing. I don't have NAV, so that doesn't explain it. Maybe I'll just set it an hour ahead and wait for it to drop an hour and it'll be correct. I really don't have any explanation for it.


If I had to try and remember, I'd say this has happened a good 10 times since picking it up just over a year ago.
 

·
Super Moderator
Joined
·
15,601 Posts
Owners manual 2016 uConnect 8.4"

You may have a '17 - many of the menus are similar.

This was a page I grabbed from the uConnect supplemental manual:

Mine was a RA3 (non Nav) system - I bought the software key afterward. Mine had the clock / use GPS settings before I did anything with mine.
 

Attachments

·
Super Moderator
Joined
·
15,601 Posts
  • Like
Reactions: number40Fan

·
Registered
Joined
·
125 Posts
Discussion Starter #11
There was an update available. Downloaded, installed and everything seemed to go OK. There is a point in the directions that state after it has completed, you should get a screen showing the current firmware loaded and that it matches what is on the USB drive and to hit the OK button. That never happened for me, even after waiting over 10 minutes. I went ahead and pulled the USB drive. Did the dealer reset which states to press the top right corner of the screen after getting into the dealer screen, but you need to press the X button.


Now, I'll just wait and see what happens and see if it fixed the issue. Thanks again, Hal.
 

·
Registered
Joined
·
16 Posts
I realize you don't have navigation but look into "Capacitor discharge and reset".

I had a similar issue on my 2017 recently following (multiple) flashes. Radio would revert to being exactly 45 minutes slow when Sync with GPS was selected. I could manually enter the time but checking the box to Sync it would revert back. Had a tech that spent about an hour on it and was ultimately able to resolve it by doing a "complete capacitance discharge"/invoice states - "Capacitor discharge and reset".

T
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
18,009 Posts
"Capacitor discharge and reset" I believe that is tech speak for disconnected the battery until all the caps had discharged, then reconnected battery. A Guy
 
  • Like
Reactions: DCSPS 2017

·
Registered
Joined
·
125 Posts
Discussion Starter #16
I do believe the update fixed my clock issues. After sitting for almost two weeks, it was still correct. Will update this post if it happens again.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
18,009 Posts
Welcome to Challengertalk ;) Have you tried changing the time format to 24 hours to see if problem persists then? if not, change it back and see if it stays correct.

I recently "fixed" an issue where my Windows 10 lock screen time was 1 hour behind, but Windows time and BIOS were correct. Even my yahoo email told me to change my time zone.

A Guy
 

·
Registered
Joined
·
160 Posts
Mine changes the wrong direction when DST changes. But it also just advanced one hour again a few days ago.

Googling shows results that some Pacificas & RAMs also have this issue. Somewhere amidst all the searching I saw something that IIRC a dealer commented about Uconnect's internal clock & I'm trying to find that link again.

How does the system know what date it is if you don't have GPS? Is there a service menu to go into that lets you look & perhaps change the date?
 

·
Registered
Joined
·
2 Posts
Anyone seen this before? Car will sit for a week or more. Jump in, fire it up, clock is off by an hour. Always an hour earlier than it should be. Plain Jane radio. I haven't found any "Time Zone" settings, so I don't really understand why it would be changing. If that was the case, you'd think it would change shortly after setting the correct time.
My clock was bad. After 3rd time they changed it.
 
1 - 20 of 25 Posts
Top