Dodge Challenger Forum banner

"damaged key"

27861 Views 8 Replies 7 Participants Last post by  MystiqMe
All of the sudden, my starter pushbutton won't start the car. The remote fob works fine at lock and unlock and trunk release, but when I get in the car I push the starter button and nothing...the dash chimes and the message "Damaged Key" flashes on the guage.

I replaced the battery, no change.

I tried my second key, no change.

Anyone have any ideas what has happened, or if there is a remedy?
1 - 9 of 9 Posts

· Registered
Joined
·
177 Posts
Go figure, we are getting the "No FOB Detected" on our dash read out. Both FOB's are doing it. Goes into the dealer tomorrow to get reflashed to fix the problem. They say that will fix it.

Maybe your could be the same kinda problem. Contact your dealer and see if there is a reflash for your prob. as well.
 

· Registered
Joined
·
28 Posts
The new FOBs seem to be a little flaky. My '10 went heywire the other day, the lights were continuously flashing, the windows would roll down by themselves and the door would not stay locked. Defective fob was sending out random signals by itself.
 

· Registered
Joined
·
2,752 Posts
All of the sudden, my starter pushbutton won't start the car. The remote fob works fine at lock and unlock and trunk release, but when I get in the car I push the starter button and nothing...the dash chimes and the message "Damaged Key" flashes on the guage.

I replaced the battery, no change.

I tried my second key, no change.

Anyone have any ideas what has happened, or if there is a remedy?

I had that happen. The key still started the car when I removed the button and used the key to turn the ignition. The failure happened suddenly and my dealer ended up replacing the key to correct it. The repair also included resetting the PEM (Passive Entry Module).
Since that repair (last September) I have had a couple brief "Key not found" events. A case was opened and if it happens again they want to replace the PEM.
 

· Registered
Joined
·
177 Posts
well they flashed ours and no luck, still getting the no fob found...:-( Dealer is looking into replacing the keys and the PEM. Gotta wait till the 18th to get it in. oh well at least the car will start with the key....:)
 

· Registered
Joined
·
2,752 Posts
I bet the PEM replacement will do it for you.
 

· Registered
Joined
·
954 Posts
All of the sudden, my starter pushbutton won't start the car. The remote fob works fine at lock and unlock and trunk release, but when I get in the car I push the starter button and nothing...the dash chimes and the message "Damaged Key" flashes on the guage.

I replaced the battery, no change.

I tried my second key, no change.

Anyone have any ideas what has happened, or if there is a remedy?
Mine is doing the exact same thing. I've just been starting it with my key lately. My basic warranty is out so I don't really want to pay to have it fixed.
 

· Premium Member
Joined
·
3,269 Posts
All of the sudden, my starter pushbutton won't start the car. The remote fob works fine at lock and unlock and trunk release, but when I get in the car I push the starter button and nothing...the dash chimes and the message "Damaged Key" flashes on the guage.

I replaced the battery, no change.

I tried my second key, no change.

Anyone have any ideas what has happened, or if there is a remedy?
Have you hooked up any aftermarket equipment lately that might interfere -like a Trinity tuner?

I would pull the fuse for the Keyless Go or disconnect the battery for a bit and see if that resets it but if you are under warranty and not an experimenter, let the dealer take care of it.

It does still start if you put the keyfob in the ignition like a regular key?
 

· Registered
Joined
·
3 Posts
Mine just started with this issue and she is a 2009 Challenger Manual 6-Speed SRT. You take the button out and press the section still in the dash and get the same response.. “chirp chirp chirp” then “Damaged Key” error code.

Put the key fob in and it starts as one would expect a car to do.

Worst part is that everything worked when I put it in the shop to get the power steering pump and hoses replaced, and now it is messed up…

Can someone tell me the easy way to "Flash" the PEM? I just had my car in the Shop (she is a 2009 SRT Challenger, Manual Transmission, with 130K miles). I had to get the Power Steering pump and hosed replaced, along with all the hoses, and had the alignment done. Then as I went to start the car when leaving the shop, the button flash a "Key In", then automatically "DING" and "Damaged Key". However the FOB works for all other Functions and I can remove the button and start the car with the FOB in like a normal key.


PLEASE HELP!!!
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top