Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter #1
Hey guys, have a 2017, been losing a few minutes here and there lately, didn't think much of it, but today I'm down a hour..........anyone else having this happen to them.

Rich
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,770 Posts
Odd, must be synced to a cellular signal as they reset automatically with daylight savings time. But even if lost signal, should sync next time acquires signal again. A Guy
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,865 Posts
The 2015-2016 had the 17.11.07 that supposedly fixes the time lose issue but at the cost of losing sport mode.
http://www.challengertalk.com/forums/7560746-post10.html

Just take it to the dealer and have THEM fix it. The last firmware update was 16.11 Rev H back in 8/2017. I would be hesitant on getting firmware updates with these uconnect units as the updates seem to fix one thing but then create a whole new set of problems.
http://www.challengertalk.com/forums/8071857-post31.html
https://dodgeforum.com/forum/dodge-charger/407049-uconnect-firmware-cr16-11-clock-and-gps-issue.html

Here is the method to check your firmware revision
http://www.challengertalk.com/forums/8063713-post4.html

You can enter your vin here to see if there are any new updates for your model
https://www.driveuconnect.com/support/software-update.html

You may also want to try having time sync or unsync with GPS in the settings.
 

·
Registered
Joined
·
185 Posts
I'll betchya this clock never lost time.
when it actually worked... I think every car I owned that ever had an analog clock, it was the first thing to stop working after the warranty ran out.:laugh2:
 
  • Like
Reactions: Robotech
1 - 7 of 7 Posts
Top