Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #1
Okay, so I finally hard wired my radar detector Smart Cord to the 12v passenger accessory plug. Looks good too. However something funny happened during the reassembly. First, when I plugged in the large cable connector, the dash said to service the shifter. I assumed this was due to the shifter cable not being plugged in yet. So I ignored it and continued putting the center console back in. After all was said and done, I put the car in On position and the shifter lights weren't on and the backup camera was showing up on the screen. I started the car and put it in Drive and the backup camera still was showing and no shifter lights on the shifter.

I popped off the plastic around the shifter and unplugged the shifter cable and plugged it back it. Put the car back in On position and the shifter lighted were on and the backup camera was off.

Now I started he car and the check engine light is on. Is this something I did? Is this due to the Service Shifter message hat came up? Will this clear itself out?

When I run the diagnostics through evic, no codes show up.

Please help as the last thing I want to do is take it to the dealer right now after I just tore out the center console.

Here's the engine light.


Here's the installation.

 

·
Registered
Joined
·
204 Posts
Discussion Starter #2
Update... check engine light went off. :). I guess it just needed to reset itself from the shifter being disconnected.

Anybody have a clue why the reverse camera was staying on?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
744 Posts
I think the electronics on these beasts are sensitive.Voltage variations up or down ie: adding an accessory could trigger some sensors/warning lights.I love my Challenger but they are not diy friendly.
 

·
Registered
Joined
·
580 Posts
Update... check engine light went off. :). I guess it just needed to reset itself from the shifter being disconnected.

Anybody have a clue why the reverse camera was staying on?


Sent from my iPhone using Tapatalk
Always disconnect the battery before working on the electronics. Reconnect the battery after all work is done. Be safe.
 

·
Registered
Joined
·
204 Posts
Discussion Starter #5
I hear you. But I removed the electronics prior to working on them. I wouldn't think you need to disconnect the battery just to unplug a cable. If that were the case how would we ever plug in our phones


Sent from my iPhone using Tapatalk
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
17,064 Posts
The phone isn't a part of the car, monitored by the car ;)

A Guy
 

·
Registered
Joined
·
110 Posts
The computer systems in these cars are getting smarter every year and they monitor voltage. The minute you cut into a factory Harness the PCM notices the resistance change. The days of everything running on 12 volts are gone. Many different voltages are used to run various systems. The 2016 systems also track foot prints when that light come on it records a system change and it can be read by the dealers computer.
 
1 - 7 of 7 Posts
Top