Dodge Challenger Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,221 Posts
Discussion Starter #1
Hey I have a 2016 Scat Pack Shaker and yesterday I noticed what sounds like a pulley bearing rattle. I made an appointment at my local Dodge dealer for tomorrow but wanted to see if anyone has had anything like this happen to their Scat Pack? I have a bit over 26K miles and about 21 months new.

Thanks
 

·
Registered
Joined
·
41 Posts
I have 3000 miles on a 2017 and intermittently mine has developed a squeak that comes and goes.

cheers
 

·
Registered
2015 RT 5.7 M6
Joined
·
7,565 Posts
Hey I have a 2016 Scat Pack Shaker and yesterday I noticed what sounds like a pulley bearing rattle. I made an appointment at my local Dodge dealer for tomorrow but wanted to see if anyone has had anything like this happen to their Scat Pack? I have a bit over 26K miles and about 21 months new.

Thanks
Wife's 2013 5.7 WK2 made a rumbling type of sound after the first year of ownership. Took it to the dealer and it was the water pump (no leaks which was strange) that they ended up replacing under warranty. Kind of makes me wonder what kind of quality parts are going on cars these days. Hopefully yours is just an idler bearing gone bad.
 

·
Registered
2016 Jazz Blue A8 Scat
Joined
·
694 Posts
There are a bunch of people who have reported water pump problems on factory Shaker 5.7 cars around 20-30k.

I'm not sure why the Shaker cars have more problems with the water pump, but it seems to be a trend.
 

·
Registered
Joined
·
1,221 Posts
Discussion Starter #6
So I just got back from the Dealer and it's the water pump. He said that there's metal pieces in the system so they want to keep it today to fully flush out the system. Hopefully the new WP isn't part of the bad batch!
 

·
Registered
Joined
·
1,221 Posts
Discussion Starter #7
I had this happen on my 2017 Scat Pack Shaker about a month ago. Took it to the dealer and it turned out to be the water pump also.
How many miles on your SPS? Just curious! I have about 26,800 on my 2016. Took delivery December 2015...
 

·
Registered
Joined
·
45 Posts
How many miles on your SPS? Just curious! I have about 26,800 on my 2016. Took delivery December 2015...
I had just 4500 when the water pump was replaced. I can't say I was happy about that happening on such a new vehicle. I hope its not an indication of poor quality parts or design! I actually diagnosed it by seeing a video another member posted on here. It seems to be more common in the 5.7 than the 6.4 HEMI, so initially I didn't think it was likely the water pump. Then I watched the video and listened to the sound posted in the thread below. Sure enough it sounded just like what I was hearing.

http://www.challengertalk.com/forums/f188/what-causing-noise-not-hemi-tick-576113/
 

·
Registered
Joined
·
1,221 Posts
Discussion Starter #9
I can't say I was happy about that happening on such a new vehicle. I hope its not an indication of poor quality parts or design! I actually diagnosed it by seeing a video another member posted on here. It seems to be more common in the 5.7 than the 6.4 HEMI, so initially I didn't think it was likely the water pump. Then I watched the video and listened to the sound posted in the thread below. Sure enough it sounded just like what I was hearing.

http://www.challengertalk.com/forums/f188/what-causing-noise-not-hemi-tick-576113/
I hear you, I was thinking the same. I had a 2010 Hemi Orange R/T auto that had the timing chain snap in the highway at just over 30k miles, 15 months old SMH... The link said there was over 3k water pump on order so it could be a bad quality batch.
 

·
Registered
2015 RT 5.7 M6
Joined
·
7,565 Posts
I hear you, I was thinking the same. I had a 2010 Hemi Orange R/T auto that had the timing chain snap in the highway at just over 30k miles, 15 months old SMH... The link said there was over 3k water pump on order so it could be a bad quality batch.
Yup that vid sounded identical to my wife's 2013 GC 5.7...sounds more like a frog croaking from far away or inside the cabin. When I installed the maggie on my challenger and replaced the snout (I was sent the wrong one...short by 1.5 inch) I had a very similar sound. At first I thought it was the water pump but it was actually the coupling in the snout re-seating. But geez that is a lot of bad pumps!!
 
1 - 10 of 10 Posts
Top