Dodge Challenger Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1
At what temp. does your R/T Hemi run at? Mine didn't come with a gauge..just says C & H...looking for some exact numbers if possible..Thanks...
 

·
Registered
Joined
·
307 Posts
Discussion Starter #3
ok im an idiot..where is that at? My 2010 R/T does not have the big info computer...just a gauge saying its either cold ,normal,or hot..
 

·
Registered
Joined
·
828 Posts

·
Registered
Joined
·
639 Posts
ok im an idiot..where is that at? My 2010 R/T does not have the big info computer...just a gauge saying its either cold ,normal,or hot..
If you have stearing wheel controls you probably have the EVIC system with the hidden menu. If not, and it's a 10 car (like my 27J car) it could be the dealer did not notify the original owner that they were suppose to be added, and were not. In 10, there was some early R/T's that were released from production so they could get them in the dealershps ASAP without the controls. They were to be added later. This was the case for me.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #6
I do have steering wheel controls...but my screen does not look like the the one in that thread...the reason why I'm asking about the temp..is currently doing a smooth n shave job on an 5.7 intake...was considering about hydro dipping it..trying to find out info on how hot the dip can go...but I'm hard at work right now ...lol...I will try the trick when I get home...Thanks for the tip!! Stimpy & SIX PACK!!
 

·
Premium Member
Joined
·
423 Posts
Temps should run on average about 220 +\-. Once warmed I see temps from 212 to 230 depending on how I'm driving and highway vs. city. That is with a stock thermostat. The 180 t-stat, I generally saw 180-200. The needle for that gauge will stay at middle if you're in this range. At 235, the needle starts rising and it peaks at ~248 (I had a t-stat fail is the only reason I know this -- my data logger showed me at 245 before I got to the side of the road and shut down.

Note, this was an after market part that failed before anyone goes bashing the car.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #8
Thanks Proximo....I love this forum...tons of info!!
 

·
Premium Member
Joined
·
624 Posts
Thanks Proximo....I love this forum...tons of info!!
I just put a 190 degree (not 180) thermostat in my car. The car runs at 195-200 degrees all the time. Now I haven't had the car out in hot ambient temperatures, so it will probably run hotter in summer.
 

·
Premium Member
Joined
·
66 Posts
I want to be sure I'm reading this correctly - some 2010 should have EVIC display but it was not enabled, and can be?
 

·
Super Moderator
Joined
·
15,331 Posts
Coolant runs from 203*-215* the OEM t-stat is rated at 203*F...
 

·
Registered
Joined
·
639 Posts
I want to be sure I'm reading this correctly - some 2010 should have EVIC display but it was not enabled, and can be?
The EVIC is there, but some 10 R/T's (unknown number) had the stearing wheel controls omitted from the factory (depending on the option package). They were suppose to be added at the dealer, but some cars were sold (like mine) before the dealer added them. The new owners were suppose to get a letter to return the car to the dealer and they would add them at no charge (this happened to me). If you own a 10 R/T (especially a 27J car) and it does NOT have stearing wheel controls you may want to contact the dealer (the dealer might add them for free). You need the stearing wheel controls to find the hidden EVIC menu. I know of NO other way to get to it.

Hope this answers your question.
 

·
Registered
Joined
·
23 Posts
I purchased my R/T in September 2013 so I haven't been thru the hotter months yet but the few months I've owned it it never goes past 217 even in traffic. But I don't use the engine cover and I bought the functional hood scoops too.
 
1 - 13 of 13 Posts
Top