Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 14 of 14 Posts

·
Registered
Joined
·
781 Posts
Discussion Starter #1
For a long time now I have been annoyed with a high pitch whistle sound coming from the engine bay at around 2000 RPMs. It was driving me nuts. It was kinda loud and distracting. I always thought it had to do with my cold air intake I installed, so I would adjust it and mess with it every now and then to try and get it to stop with no luck. Well, the other day I removed my BT catch can for unrelated reasons and voila... The whistle is now gone! Go figure. Anyone else have this issue?


Sent from AutoGuide.com App
 

·
Registered
Joined
·
347 Posts
I'm having the same issue with my 2011 SE When Starting it up Sometimes.I don't have a catch can I'm Thinking it's My Throttle Body Or My Tension Belt
 

·
Premium Member
Joined
·
667 Posts
Yesterday, when I pulled our 2011 SE into the garage, I heard a very distinct whistle sound. I was tired so I decided to check it out tomorrow (now today). Last night, I happened to read this thread......

Today I pull the car out, hear the sound a little, and pop the hood. It seems louder today, and more like a bad bearing. It also seemed to be coming from around the alternator. I had a number of errands to run, but I figured I would be calling the dealer later, because the car only has 26 thousand miles on it, so it was going to be checked under warranty.

I made it about 3 miles or so to our bank drive thru atm. Yep, right in the drive thru....... I heard a couple of warning chimes, then nothing, then every light on the dash lit up and then it died..... Lucky there is a slight incline in the drive thru lane, so I was able to let the car roll back about 15 feet out of the lane. A few minutes later I was able to re-start it, for about 10 seconds, THEN it was totally DOA, I couldn't even turn on the ignition to get it out of park.

Thank God that I got the windows down before it was totally gone, I had to wait an hour for roadside assistance to come in the mid-90's heat. When the flatbed showed, it took us a while to find out how to manually disengage the park-interlock, and get the car into neutral.

So, tonight it sits in at the dealer. Not a sign of life at all. I think the alternator totally went and the car was only running on the battery, once that was gone, it was all over.

It's the first time in decades that a car has left me stranded on the side of the road. Tomorrow, they're going to let me know what they find.
 

·
Registered
Joined
·
535 Posts
I'm having the same issue with my 2011 SE When Starting it up Sometimes.I don't have a catch can I'm Thinking it's My Throttle Body Or My Tension Belt
I had a nasty whistle on my ram after I installed an aftermarket TB.
 

·
Premium Member
2014 rt shaker
Joined
·
750 Posts
I hear a whistle sound when I shut mine off... Not every time, but often.
It dies before I can pin point where it's coming from (about 15sec or so).
 

·
Registered
2012 challenger srt
Joined
·
1,951 Posts
Yesterday, when I pulled our 2011 SE into the garage, I heard a very distinct whistle sound. I was tired so I decided to check it out tomorrow (now today). Last night, I happened to read this thread......

Today I pull the car out, hear the sound a little, and pop the hood. It seems louder today, and more like a bad bearing. It also seemed to be coming from around the alternator. I had a number of errands to run, but I figured I would be calling the dealer later, because the car only has 26 thousand miles on it, so it was going to be checked under warranty.

I made it about 3 miles or so to our bank drive thru atm. Yep, right in the drive thru....... I heard a couple of warning chimes, then nothing, then every light on the dash lit up and then it died..... Lucky there is a slight incline in the drive thru lane, so I was able to let the car roll back about 15 feet out of the lane. A few minutes later I was able to re-start it, for about 10 seconds, THEN it was totally DOA, I couldn't even turn on the ignition to get it out of park.

Thank God that I got the windows down before it was totally gone, I had to wait an hour for roadside assistance to come in the mid-90's heat. When the flatbed showed, it took us a while to find out how to manually disengage the park-interlock, and get the car into neutral.

So, tonight it sits in at the dealer. Not a sign of life at all. I think the alternator totally went and the car was only running on the battery, once that was gone, it was all over.

It's the first time in decades that a car has left me stranded on the side of the road. Tomorrow, they're going to let me know what they find.
Pull out either the mustang or the camaro that you own and drive yourself back to their forum.
 

·
Premium Member
Joined
·
667 Posts
Pull out either the mustang or the camaro that you own and drive yourself back to their forum.
What the......???????

What is your problem? Where do you see anything about now hating Challengers or Dodge or Chrysler? I would NEVER own a Camaro, maybe a Mustang if I was less than 6' 3" tall. I've owned an 86 Plymouth Reliant, (omg), lasted 12 years, a 97 Stratus, the wife and I owned 4 different PT Cruisers (2 each) over a 8 year period, a 2006 Dodge Charger, and now a Dodge Challenger. See a pattern here?

As a matter of fact, our 2011 Challenger was fixed, under warranty, and ready to go by 2pm. The alternator died and I guess the battery fried. However, I didn't bring it home, a VERY good salesman convinced me to trade it in on a 2014 Torred SXT Challenger.

I was going to take some pictures, but it was dark before I got home, and I have to take it back tomorrow to have the fog lights and remote start installed.

So, your comment was either because you had a REALLY bad day, you were joking and I'm humor-impaired, or you're a complete moron, which is it?
 

·
Premium Member
Joined
·
10,036 Posts
Congratulations, enjoy the new car.
 

·
Premium Member
Joined
·
1,434 Posts
Congrats on the new car
 

·
Registered
2012 challenger srt
Joined
·
1,951 Posts
What the......???????

What is your problem? Where do you see anything about now hating Challengers or Dodge or Chrysler? I would NEVER own a Camaro, maybe a Mustang if I was less than 6' 3" tall. I've owned an 86 Plymouth Reliant, (omg), lasted 12 years, a 97 Stratus, the wife and I owned 4 different PT Cruisers (2 each) over a 8 year period, a 2006 Dodge Charger, and now a Dodge Challenger. See a pattern here?

As a matter of fact, our 2011 Challenger was fixed, under warranty, and ready to go by 2pm. The alternator died and I guess the battery fried. However, I didn't bring it home, a VERY good salesman convinced me to trade it in on a 2014 Torred SXT Challenger.

I was going to take some pictures, but it was dark before I got home, and I have to take it back tomorrow to have the fog lights and remote start installed.

So, your comment was either because you had a REALLY bad day, you were joking and I'm humor-impaired, or you're a complete moron, which is it?
Well if I was wrong then you have my apologies. It sounded like so many of the post that the trolls on here post. You know how they are. I really love this car but every thing on it has broken latest one and some thins twice I was in the middle of rush hour traffic and on and on. Glade you got it fixed and enjoy the car.
 

·
Super Moderator
Joined
·
14,917 Posts
For a long time now I have been annoyed with a high pitch whistle sound coming from the engine bay at around 2000 RPMs. It was driving me nuts. It was kinda loud and distracting. I always thought it had to do with my cold air intake I installed, so I would adjust it and mess with it every now and then to try and get it to stop with no luck. Well, the other day I removed my BT catch can for unrelated reasons and voila... The whistle is now gone! Go figure. Anyone else have this issue?

Sent from AutoGuide.com App
It sounds like you had a vacuum leak in one of the catch can hoses.
 

·
Registered
Joined
·
347 Posts
Next time I start up my car I'll record it. It only makes a Whistle Noise When It's Been Sitting For A Long Time.


@DJPiezo
 
1 - 14 of 14 Posts
Top