Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
624 Posts
Discussion Starter #1 (Edited)
So I intalled the 93 tune on my car and got on it to test it out at WOT. Well now my esp/bas light is on and wont go off...is this normal when installing the 93 tune? It wasnt on before I installed it...:werd:
 

·
Registered
Joined
·
329 Posts
When you uploaded the tune did you disable traction control? If not sometime some tunes just act weird with certain cars.
 

·
Registered
Joined
·
624 Posts
Discussion Starter #3
I dont think I did...I tried reloading it again but the light stayed on. I noticed it turned on after I leaned into a turn pretty good..but I think its weird it won't turn off now. I tried hitting the esp button in my car (have a 2010 SE) but it does nothing. I don't see any options on the intune for traction control
 

·
Registered
Joined
·
329 Posts
Hmm I'm not sure...it may be something you want to shoot towards diablosport. I know on my first challenger the speedometer wouldn't work on the 91 tune but would with the 93 tune. Try the 91 and see if the same thing happens.
 

·
Registered
Joined
·
624 Posts
Discussion Starter #5
okay so maybe i started freaking out a little too soon lol...I took the car back out and drive out like a normal person and the light turned off. whew...thx
 

·
Registered
Joined
·
1,415 Posts
If you turn off traction control when loading the tune the lights will stay on during the current key cycle. Once you turn off and restart they will be off.
 
1 - 6 of 6 Posts
Top