Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hi hope someone can help
i have a 2010 challenger srt8 problem is when turning ignition on i get abs light but not the traction control start the engine all lights go out as they should
when driving push esp button nothing happens so don't know if its on or off
used a scanner to read codes says steering angle sensor not calibrated
used scanner to calibrate says successful but still have codes that its not and no indication on dash
there no indication on dash that its got traction control at all
any help would be welcome
im in uk so may take a awhile to answer back
 

·
Registered
2010 Challenger SRT 6spd detonator yellow
Joined
·
529 Posts
hi hope someone can help
i have a 2010 challenger srt8 problem is when turning ignition on i get abs light but not the traction control start the engine all lights go out as they should
when driving push esp button nothing happens so don't know if its on or off
used a scanner to read codes says steering angle sensor not calibrated
used scanner to calibrate says successful but still have codes that its not and no indication on dash
there no indication on dash that its got traction control at all
any help would be welcome
im in uk so may take a awhile to answer back
If I remember correctly push and hold ESB with motor running in park or neutral and brake on for 10 seconds......turns complete system off
 
1 - 2 of 2 Posts
Top