Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
196 Posts
Discussion Starter #1
I have an 09 SRT, with around 1500 miles. When I pulled into the garage today, suddenly it sounded like a fan noise or vibration sound.Then the fans shutdown. I let it idle & then the fan went back on & sounded norm. I went back out for another ride, came back & all seems ok. Should I pull the fan assembly & check it? anything to worry about? If I pull it out can everything be done from the top? Don't want to go to the dealership, I rather do it myself, if you know what I mean...Thanks in advance, hope you can help...
 

·
Registered
Joined
·
4,964 Posts
'10 SRT8. Had a loose radiator rubber baffle that got stuck in the bottom of the fans making a vibration/clicking noise. Had to fish it out.

There is a dealer service on this and if you're still under your 36,000mi warranty, you should be ok with stopping by and getting it fixed.
 

·
Premium Member
Joined
·
196 Posts
Discussion Starter #4
Thanks for the input, I guess I'll check it myself. I have bad experiences all the time with service dept's. I won't go back unless theres no other way. What was lose on yours, the shroud screws?
 

·
Registered
Joined
·
416 Posts
'10 SRT8. Had a loose radiator rubber baffle that got stuck in the bottom of the fans making a vibration/clicking noise. Had to fish it out.

There is a dealer service on this and if you're still under your 36,000mi warranty, you should be ok with stopping by and getting it fixed.
Yep. My Charger had these plastic/rubber "gasket" fan things pop out... made a weird sound. Got a flashlight and took a look. Sure enough that's what happened. One fell out and was just sitting in there; the other was partially out (hard to see).

Got myself a plumber's retriever tool (long spring device with a "claw" on the end of it) and got both out in a snap. Now, no fan issues.
 

·
Premium Member
Joined
·
196 Posts
Discussion Starter #6
Yep. My Charger had these plastic/rubber "gasket" fan things pop out... made a weird sound. Got a flashlight and took a look. Sure enough that's what happened. One fell out and was just sitting in there; the other was partially out (hard to see).

Got myself a plumber's retriever tool (long spring device with a "claw" on the end of it) and got both out in a snap. Now, no fan issues.
Thanks All. going to check myself......
 

·
Registered
Joined
·
3,380 Posts
my IE was delivered w/o a functioning fan....i took it in, they hit it with a hammer and it started working, but made some noise......they replaced it in 15 minutes..

maybe the Challenger has a cheap fan prone to issues?
 
1 - 7 of 7 Posts
Top