Dodge Challenger Forum banner

1 - 20 of 27 Posts

Registered
2018 Billet Silver SRT 392 (1 of 2)
Joined
137 Posts
Discussion Starter #1 (Edited)
Hey All,

I've only had my 2018 SRT 392 for about six weeks and was presented with my first UConnect update a couple of days ago. Because of some of the horror stories I've read on this forum, I simply chose not to update. However, today, when I drove the car, I was all but forced to update. The Update screen overrode my SRT and Perfomance Pages, CarPlay, regular Bluetooth iPhone connection and other stuff. So, I bit the bullet and chose to schedule the update. It said the car needs to be off and in Park. I don't know what to expect tomorrow when I start it up! Fingers crossed.

By the way, should I be surprised I experienced this type of behavior? I thought I'd be able to ignore the update for as long as I wanted. Well, technically, I probably could've but I wouldn't have access to the items mentioned above.

I also wanted to add that I went to this site and entered my VIN where they proceeded to tell me my car is up-to-date. Yet, I've been receiving the Update dialog box on my UConnect system for a few days now.

saint 0:)
 

Registered
2018 Billet Silver SRT 392 (1 of 2)
Joined
137 Posts
Discussion Starter #2
Update: I started my car yesterday and was greeted with something like "The update was successfully installed". Everything seems to be fine and I think I notice a new choice on the initial "Accept" screen. There's now a choice for Drive Mode that I swear wasn't on there before. As you can tell, I'm not 100% sure since I haven't had the car for very long. I looked all over for the version my Uconnect is running but can't find it. I thought it was under Apps > Settings > System Info but it's not there. Where should I be able to find that information?

Thanks,

saint 0:)
 

Registered
Joined
324 Posts
I just for the heck of it checked my version and my software version is my build date. 16.09.09. I went to the site to check for updates.
YOUR VEHICLE IS UP TO DATE
There are no updates available at this time for your 2016 equipped with this system.
I'm wondering if this a problem trying to do the updates when they say there is none? I see at the bottom that there is a reset to factory default. If there were any issues could we reset it back with no issues? I'm a little Leary in doing this update myself. What's included in the update? I have not read further into it and I'll probably do more research on this.
 

Registered
2015 RT 5.7 M6
Joined
7,576 Posts
Once you perform the upgrade you cannot undo it. The factory reset is to change setting back to default. The new firmware for 2015-2016 allows dragging and dropping apps in the bottom of the screen and some other stuff....not enough to risk sport mode though.

SYMPTOM/CONDITION:
The following improvements are included in this update:
路 Adds Apple Siri庐 Eyes Free capability for iPhone庐 owners.
路 Auto Play can now be configured.
路 Adds do not disturb text message feature.
路 The ability to drag and drop icons into the menu bar.
路 Fix for radio locks up/frozen.
路 Fix for stuck on black/blank screen.
路 Human Machine Interface (HMI) improvements.
路 Several navigation improvements.
路 Fix for radio loses time.
路 Charge Complete notification is not received (RU PHEV only).
路 Media devices, Phone pairing and Bluetooth usage improvements.
路 Improved tuner performance.
路 Enhanced Voice recognition (VR) performance.
路 Enhancements in Connectivity Apps (Yelp, Pandora, Aha, etc).
 

Super Moderator
Joined
15,391 Posts
I just for the heck of it checked my version and my software version is my build date. 16.09.09. I went to the site to check for updates.
YOUR VEHICLE IS UP TO DATE
There are no updates available at this time for your 2016 equipped with this system.
I'm wondering if this a problem trying to do the updates when they say there is none? I see at the bottom that there is a reset to factory default. If there were any issues could we reset it back with no issues? I'm a little Leary in doing this update myself. What's included in the update? I have not read further into it and I'll probably do more research on this.
It might be that the website has been stopped from allowing v17.11.07 update to go out. This will avoid others having the misfortune of the issues that the '15 / '16s have experienced.
 

Registered
Joined
324 Posts
Once you perform the upgrade you cannot undo it. The factory reset is to change setting back to default. The new firmware for 2015-2016 allows dragging and dropping apps in the bottom of the screen and some other stuff....not enough to risk sport mode though.

SYMPTOM/CONDITION:
The following improvements are included in this update:
路 Adds Apple Siri庐 Eyes Free capability for iPhone庐 owners.
路 Auto Play can now be configured.
路 Adds do not disturb text message feature.
路 The ability to drag and drop icons into the menu bar.
路 Fix for radio locks up/frozen.
路 Fix for stuck on black/blank screen.
路 Human Machine Interface (HMI) improvements.
路 Several navigation improvements.
路 Fix for radio loses time.
路 Charge Complete notification is not received (RU PHEV only).
路 Media devices, Phone pairing and Bluetooth usage improvements.
路 Improved tuner performance.
路 Enhanced Voice recognition (VR) performance.
路 Enhancements in Connectivity Apps (Yelp, Pandora, Aha, etc).
The dropping and dragging: I actually watched my sales rep do this in front of me when we were going thru the car on delivery. Other than that I鈥檝e had no issues as of yet being I only have just under 10,000KM / 5800miles on it. I certainly won鈥檛 risk losing sport mode for an update I don鈥檛 need as of now.
 

Registered
2016
Joined
394 Posts
Update: I started my car yesterday and was greeted with something like "The update was successfully installed". Everything seems to be fine and I think I notice a new choice on the initial "Accept" screen. There's now a choice for Drive Mode that I swear wasn't on there before. As you can tell, I'm not 100% sure since I haven't had the car for very long. I looked all over for the version my Uconnect is running but can't find it. I thought it was under Apps > Settings > System Info but it's not there. Where should I be able to find that information?

Thanks,

saint 0:)
With The 17+ radio's to see software version you need to hold driver side hot/cold/front defrost for about 5-6 seconds. Then in dealer mode I believe its under radio, is all your radio info like software/hardware versions and a few other items.

Ron
 

Registered
2018 Billet Silver SRT 392 (1 of 2)
Joined
137 Posts
Discussion Starter #11
With The 17+ radio's to see software version you need to hold driver side hot/cold/front defrost for about 5-6 seconds. Then in dealer mode I believe its under radio, is all your radio info like software/hardware versions and a few other items.

Ron
Thanks! I'll give that a try next time I'm in the car.

saint 0:)
 

Super Moderator
Joined
15,391 Posts

Registered
Joined
62 Posts
The only update worth doing to any Uconnect device is driving a large screwdriver through the screen with a big hammer.
 

Super Moderator
Joined
15,391 Posts
The only update worth doing to any Uconnect device is driving a large screwdriver through the screen with a big hammer.
Can someone photoshop that and create a meme?

We probably have a lot of willing contributors for that topic!:headbang:
 

Registered
Joined
12 Posts
I'm glad I'm not alone

I'm late to the thread but am very happy to hear I'm not the only one with UConnect issues. Couple notes:

--I have a '16 SRT 392. I love my Chally more than life itself and have zero other issues with it
--UConnect worked perfectly until six-eight months ago when UConnect updates were pushed to my Android Phone (Samsung 8+). From that point on, I get three songs in Slacker and Pandora (and about five minutes in Aha). Then, the connection to the phone is lost with my only recourse being to stop and start My Connect. Even thinking about touching a cell phone in the state of Washington while driving is pretty much illegal so I'm forced to stop the car and mess around with the application. All that does is reset my time so I get another 10 minutes before it screws up again. Big deal. Multiple calls to UConnect support and goodness knows how many resets of my connection to the music services have resulted in zero improvement.
--I also got the software update to the Chally software. Other than some different messaging, I've not noticed any change to anything: UConnect continues to reliably screw up. Everything else works OK.
--I have no disconnect problems with Audible -- or any other Bluetooth-based service that talk to the car.

FYI, given that UConnect music is pretty much useless, I've started using Tidal music service via Bluetooth because it's high fidelity. The quality is nearly as good as the UConnect music apps.
 

Registered
Joined
1,237 Posts
I'm late to the thread but am very happy to hear I'm not the only one with UConnect issues. Couple notes:

--I have a '16 SRT 392. I love my Chally more than life itself and have zero other issues with it
--UConnect worked perfectly until six-eight months ago when UConnect updates were pushed to my Android Phone (Samsung 8+). From that point on, I get three songs in Slacker and Pandora (and about five minutes in Aha). Then, the connection to the phone is lost with my only recourse being to stop and start My Connect. Even thinking about touching a cell phone in the state of Washington while driving is pretty much illegal so I'm forced to stop the car and mess around with the application. All that does is reset my time so I get another 10 minutes before it screws up again. Big deal. Multiple calls to UConnect support and goodness knows how many resets of my connection to the music services have resulted in zero improvement.
--I also got the software update to the Chally software. Other than some different messaging, I've not noticed any change to anything: UConnect continues to reliably screw up. Everything else works OK.
--I have no disconnect problems with Audible -- or any other Bluetooth-based service that talk to the car.

FYI, given that UConnect music is pretty much useless, I've started using Tidal music service via Bluetooth because it's high fidelity. The quality is nearly as good as the UConnect music apps.


It's pissed you are calling your Challenger chally...:x
 

Registered
Joined
52 Posts
Update: I started my car yesterday and was greeted with something like "The update was successfully installed". Everything seems to be fine and I think I notice a new choice on the initial "Accept" screen. There's now a choice for Drive Mode that I swear wasn't on there before. As you can tell, I'm not 100% sure since I haven't had the car for very long. I looked all over for the version my Uconnect is running but can't find it. I thought it was under Apps > Settings > System Info but it's not there. Where should I be able to find that information?

Thanks,

saint
I had my update about a week ago, but no drive mode on accept screen. Until today after I installed my tazer. So I took it as my tazer that caused that? But your saying you got it from the update so now I鈥檓 confused.
 

Registered
2018 Billet Silver SRT 392 (1 of 2)
Joined
137 Posts
Discussion Starter #20
I had my update about a week ago, but no drive mode on accept screen. Until today after I installed my tazer. So I took it as my tazer that caused that? But your saying you got it from the update so now I鈥檓 confused.
I think so. I haven't had the car for very long but I really don't think it showed up until after the latest update.

saint 0:)
 
1 - 20 of 27 Posts
Top