Dodge Challenger Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
654 Posts
Discussion Starter #1
Well, if you read my other thread on a Dead Alternator at
http://www.challengertalk.com/forums/f170/dead-alternator-111258/

That was the start of this... The dealer got my car on Monday afternoon, called me Tuesday said they would have the Alternator Tuesday, it did not arrive until today.

They put it on, along with a new battery because they were getting battery codes as well.

Fired it back up again, and alternator still putting out zero volts. They did further and found that a main fuseable link in the primary engine harness cooked.

Ok. So put a new fusible link in, done deal... not so easy. Apparently its integrated into the main harness and requires a new harness.

Problem --- Not a single harness exists ANYWHERE.

Problem --- My Dodge rental coverage is good for 5 days only.

So now, both the dealer and myself are talking to SRT Support Thursday to find out options....

:icon_flaming: :ninja::icon_confused:
 

·
Registered
Joined
·
6,342 Posts
Holy fried cluster of wires batman! That freaking STINKS!!!!

:(
 

·
Premium Member
Joined
·
654 Posts
Discussion Starter #4
Well, Chrysler has told me they can't buy from a outside source.... so the SRT team has escalated this to parts expedite. They have had to extend my rental car....

I first started out with a Chrysler 200.... drove it for 2 days, could not stand it... I am 6'5" tall and did not fit, so of all things they got me was a Chrysler Mini Van.. UGH!!! but that is only until Monday, as all rentals in the area were sold out.

On Monday I am getting a Charger until I get my baby back.... which I hope is sooner than later.
 

·
Premium Member
Joined
·
654 Posts
Discussion Starter #6
we have a dealer that will put it back into Chrysler inventory system so they can get it but it might take a few days.
Can you PM me the part #, and then on Monday I will have my dealer verify that its what they need, if so then go from there.
 
1 - 6 of 6 Posts
Top