Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
288 Posts
Discussion Starter · #1 ·
Need your help peepz,

Got myself a 2016 Challenger Scat Pack back in September of 2016. Unfortunately, of the timing i did not get the Convenience Package. Freaking bummer really. So which means no stock HID's. Since then i did an upgrade with HID's few months later. Well, that time I ended up having issues with it where the headlights would shut off randomly and at times for seconds at a time. Seconds I mean like 4 to 10 seconds. ( Dangerous as hell, especially when i ended up going out of town and driving back at night time. Thankfully had the stocks in my glove box) After that tried cancelers, relay harness and so on. No success. Few months later i ended up finding a shop that did a relay harness kit with some resistors. Only thing that would happen, that it would stay on but i would get a 1 second blink at random times. Bothered me, but better than them shutting off as before.

Had this kit for about a year, baring it...but started to notice that 1 second blink would happen a little more often. I'm guessing the resistors were already getting old. Unfortunately, the shop closed down so i could not get the same wiring kit.

Buddy of mine owns an audio and light shop and told me he tried some canbus led kit with some cancelers on his wife's challenger with no problem whatsoever. So i bought the kit..worked for about a day or two..and back to the same random shut offs.

So, fed up...and annoyed i ended up buying a kit with relays, resistors, that is meant for Mopar flickers online. $100 bucks. Installed yesterday and drove like a charm. BUT..... JUST TODAY, drove and got the 1 second flicker back. Does not completely shut off but still have the random 1 second flicker.

"The 15+ Mopar Spec harness is properly calibrated to tame the canbus system on the new Mopar vehicles. Using a quad configuration for it's load resistors that's unique only to this harness in conjunction with a special anti-flicker capacitor and twin relays - the harness will absorb any pulsing signals emitted from the stock output for uninterrupted relay function. No flickering or pulsing!"

HAS ANYONE FIXED THIS ISSUE???!!!!

I CANT DEAL WITH THIS NO MORE!!!:crying:

(Morimoto kit wiring)
 

Attachments

·
Registered
Joined
·
288 Posts
Discussion Starter · #2 ·
Fed up with MY HID CONVERSION!! 2016 CHALLENGER SCATPACK (flicker)

Need your help peepz,

Got myself a 2016 Challenger Scat Pack back in September of 2016. Unfortunately, of the timing i did not get the Convenience Package. Freaking bummer really. So which means no stock HID's. Since then i did an upgrade with HID's few months later. Well, that time I ended up having issues with it where the headlights would shut off randomly and at times for seconds at a time. Seconds I mean like 4 to 10 seconds. ( Dangerous as hell, especially when i ended up going out of town and driving back at night time. Thankfully had the stocks in my glove box) After that tried cancelers, relay harness and so on. No success. Few months later i ended up finding a shop that did a relay harness kit with some resistors. Only thing that would happen, that it would stay on but i would get a 1 second blink at random times. Bothered me, but better than them shutting off as before.

Had this kit for about a year, baring it...but started to notice that 1 second blink would happen a little more often. I'm guessing the resistors were already getting old. Unfortunately, the shop closed down so i could not get the same wiring kit.

Buddy of mine owns an audio and light shop and told me he tried some canbus led kit with some cancelers on his wife's challenger with no problem whatsoever. So i bought the kit..worked for about a day or two..and back to the same random shut offs.

So, fed up...and annoyed i ended up buying a kit with relays, resistors, that is meant for Mopar flickers online. $100 bucks. Installed yesterday and drove like a charm. BUT..... JUST TODAY, drove and got the 1 second flicker back. Does not completely shut off but still have the random 1 second flicker.

"The 15+ Mopar Spec harness is properly calibrated to tame the canbus system on the new Mopar vehicles. Using a quad configuration for it's load resistors that's unique only to this harness in conjunction with a special anti-flicker capacitor and twin relays - the harness will absorb any pulsing signals emitted from the stock output for uninterrupted relay function. No flickering or pulsing!"

HAS ANYONE FIXED THIS ISSUE???!!!!

I CANT DEAL WITH THIS NO MORE!!!

(Morimoto kit wiring)
 

Attachments

·
Registered
Joined
·
37 Posts
I had the same issue with my Chrysler 200 I went through several different bulbs and kits one similar to what you have but I absolutely hated that kid as the resistors got so hot in addition to the fact that the wires failed in the resistor housing a few times (morimoto kit from the retrofit source).
I had tried LED bulbs but they only worked for a few weeks and did not nearly put out enough lumens in the distance
The best luck I had was this kit-- it is works well with FCA vehicles with this canbus set up:

DDM Tuning: HID and LED Lighting

Good luck!
 
1 - 3 of 3 Posts
Top