Dodge Challenger Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Got this 2013 sxt a couple days ago. Now check this out. Engine light on, abs light on, and brake light on. Driving down the highway speed hand drops to zero and car still drives. Stops at light. Now trans is in first gear and will not change with increased speed. Pulled over and shut car off. Wont start. Put foot on brake and press button not a peep. Anyone have a clue what this could be or has had this happen to them.
 

·
Premium Member
Joined
·
919 Posts
If you bumped the shifter to the right with your arm, you put it into manual mode and would have to continue to manually shift from there until putting it back to auto mode (I did this and had to figure out what happened). You don't say if you bought it from a dealer new or used and if used, how many miles on it.
 

·
Registered
Joined
·
504 Posts
At your front tipm module in the engine compartment is relay 22 run/start. Pull that relay and then plug it back in to see if it works. I have had this happen several times and the only way to get my car to start is to pull this relay. I just got a new on and I will see if this has resolved the problem.

Good luck.

Todd
 

·
Registered
Joined
·
54 Posts
Might be worth getting your battery checked.

These days, to make the computer work properly they have to maintain a minimum voltage.

I realize your's isn't very old but if it was fully discharged a few times before you got it the battery could be weak.
 
  • Like
Reactions: Shads Challenger
1 - 6 of 6 Posts
Top