Dodge Challenger Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
332 Posts
Discussion Starter #1
Today I was driving my 2015 SPS and my DID reads "service electronic stability system".
:|
The ABS light and traction control light are also lit up.
Cruise does not work, and sport mode is acting funny as well.

Called the dealer but have to wait about a week for an appointment...

Do you think it will hurt to drive the car?

Planned on going on vacation this weekend (about a 100 mile trip).

Any comments, commiseration, or other advice/ info is appreciated.
:umbrella:
 

·
Premium Member
Joined
·
9,370 Posts
I despise acronyms, what is your DID?
You may know but surely I'm not the only one who thought what is that. Or to use a very common acronym, WTF.
 

·
Registered
Joined
·
332 Posts
Discussion Starter #4
I despise acronyms, what is your DID?
You may know but surely I'm not the only one who thought what is that. Or to use a very common acronym, WTF.
DID is the driver information display.
It is on the dash between the tach and speedo...


You are not alone yellow jacket, IDA* as well.

:wink3:

*= i despise acronyms
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
17,045 Posts
I thought that was EVIC (Electronic Vehicle Information Center)

A Guy
 

·
Registered
Joined
·
694 Posts
agreed, don't take it to a stealership, cost me over $400. they forced me to find a real good mechanic which i now have.
 

·
Registered
Joined
·
671 Posts
Had the same thing happen twice and both times it was bad wheel speed sensors and both times they fixed it for free, and it wont hurt to drive the car, but just be careful the wheels will spin a little easier.
 
1 - 12 of 12 Posts
Top