Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
has anyone experienced the headlights flicker when you apply the brake. this happens on high or low beam. dealer was no help..:notallthere:
 

·
Registered
Joined
·
780 Posts
Problem with 300's as well for a bit . Was told that corrosion on connection may cause. My dealer was good and fix under warranty with my 300 but I have heard horror stories
 

·
Registered
Joined
·
207 Posts
I saw it today! Thought I was imagining it. Definitely going to dealer. Wonder if the sequential tail lights affecting the power flow?
 

·
Registered
Joined
·
29 Posts
Not sure if this is the same, but as I was sitting on the side of the tollway, waiting for my second ticket in two weeks, I noticed that all my lights were erratically pulsing. I first noticed it with the interior reading lights, but then when looking saw it everywhere. It seemed to be far more pronounced when I had the flashers on. THe strange piece was that it didn't pulse with the flashing, it was odd and had no discernible pattern.

When I get it back from the dealership, I'll need to be more aware.
 

·
Registered
Joined
·
619 Posts
Yes, they do flicker when you apply the brakes. "Normal" for Chrysler. My sons PT crusier does it too. My GM cars never do this. Just a Chrysler thing I guess.

Last thing I need is to take it to a dealer and let them play with my wiring system.
 

·
Registered
Joined
·
172 Posts
Have not noticed my R/T doing it but my 2009 300C does it. They are the same body type (LX) must be something in the computer program?

I have never had any other issues coming up because of it, it has done it since it was brand new.
 
1 - 9 of 9 Posts
Top