Dodge Challenger Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1 (Edited)
I have been searching far and wide for the answer to this, my dealership nor dodge could assist me. My interior lights (as well as other auxiliary interior lights) do not work in my 2013 Challenger SXT, the bulbs have been replaced already to be sure, and I cannot determine which fuse may be causing the issue (IF the fuse is the issue) because it is not listed in the manual anywhere. I have seen others post this question on different forums and still have not found the answer to this day.

If anyone has an idea please disclose it below.
 

·
Registered
Joined
·
108 Posts
I checked my manual and you are right, they seem to have left that one out. Try #9 20 amp yellow in the trunk. It's labeled for the power outlet, and it seems like the right place to also have the interior lighting.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
I checked my manual and you are right, they seem to have left that one out. Try #9 20 amp yellow in the trunk. It's labeled for the power outlet, and it seems like the right place to also have the interior lighting.
I gave it a try but unfortunately it wasn't the right one. Thanks for the input though, I also tried the cargo light fuse and that didn't work either.

I am stumped here, dodge themselves don't know
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,798 Posts
Is there a fuse in #17 in the rear? I remember the older Magnum owners had an unmarked fuse in #17 that killed the interior lights when it was pulled. A Guy
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
Is there a fuse in #17 in the rear? I remember the older Magnum owners had an unmarked fuse in #17 that killed the interior lights when it was pulled. A Guy
Yeah, it's labeled as the instrument cluster, which is functioning and appears independent of the interior lights
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Pulled and replaced a few fuses today that I thought it may have been, #17 #18 #38 etc. Still nothing, searched the internet far and wide and those threads remain unsolved as well
 

·
Registered
Joined
·
863 Posts
I would think you checked this, but, did you check the Rheostat? (Dimmer control). I have seen these turned off in the past!
Just a thought.
Tom.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #9
Maybe try reseating the IOD...see this thread. http://www.challengertalk.com/forums/f108/anyone-familiar-w-transport-fuse-33108/ shot in the dark.
Saw that on another thread and tried that, sadly it didn't work

I would think you checked this, but, did you check the Rheostat? (Dimmer control). I have seen these turned off in the past!
Just a thought.
Tom.
I have tried the dimmer switch in every position possible, no effect except on the instrument cluster
 

·
Registered
Joined
·
1,449 Posts
Still have no working solution, checked everywhere I could think of.
The interio lamp driver is in the instrument cluster. You need to check the lamp circuit for a short to ground wich would cause the lamp driver to fail. If no short to ground in the lamp circuit then I recomend replacing the instrument cluster
 

·
Registered
Joined
·
45 Posts
Discussion Starter #12
The interio lamp driver is in the instrument cluster. You need to check the lamp circuit for a short to ground wich would cause the lamp driver to fail. If no short to ground in the lamp circuit then I recomend replacing the instrument cluster
So it may not be a fuse it may be a ground wire? Got a draw-up or anything on this?
 

·
Registered
Joined
·
1,449 Posts
I'm not working at a dealer at the moment maybe someone else can get you one. It sounds like you have a bad cluster. You need to make sure you dont have a short to ground in the lamp circuit before replacing the cluster or th
 

·
Registered
2018 PCP Challenger Scat Pack w/dynamics
Joined
·
42 Posts
Sorry for the super late post, but I've been having tons of electrical problems with my '13 sxt as well. First it started with the trunk not working. Then my key fob stopped working (lock/unlock & push to start). Next my interior lighting would only turn on when the brightness dial was turned all the way up, or the door had to be open. The dealership couldn't figure it out, so I took it to a respectable local shop. They replaced the cluster, some things were fixed, but later all of the problems came back. After weeks of trouble shooting, they just weren't able to locate the issue. So after about $3k in repairs, I'm back to square one :c . Interior lights still don't work, I have to lock my doors manually, and the trunk doesn't open at all. Only way to use it is by climbing through the rear seat and pulling the emergency latch lol. At this point, I think I'll just have to sell it. I love my car, but I just can't put any more money in.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,798 Posts
I think the trunk latch is your prime suspect


A Guy
 
1 - 15 of 15 Posts
Top