Dodge Challenger Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
585 Posts
Discussion Starter #1
Ok, so I go to take my car out this morning after its been sitting for about ten days and it wont start. I was running late for work so I didn't investigate it at all but it sounded like it may be a weak battery. It wouldn't crank at all. It just kind of gave me a grunt. All of the idiot lights came on in the dash but she wouldn't start. A few things to note, I installed the lockpick about a week before chrstmas and everything was fine after that but I only used the car a few times after that and it never sat for more than aday or so. Also while I was running the wires for the rear camera I noticed that my battery had corrosion all over the neg post and that some acid was leaking from the battery as well. Would this kill my battery enough that I wouldn't be able to turn over the engine but all the lights would come on? Does anyone know what the battery voltage needs to be to start the car? I figure that would be the place to start cause if its reading like 11 volts or so then. I would assume my battery is NG and needs to be replaced. On a side note I backed my car into the garage and there's not alot of room to work in the trunk, is ther a way to jump the car from the front under the hood somewhere? Thanks in advance for all ur help,


Jim.
 

·
Premium Member
Joined
·
2,328 Posts
Try and clean the corrosion with terminal cleaners first. If that don't work you probably need a battery. I haven't look for jumper post's under the hood. You can charge from the hot wire off the alternator but that takes a while not a real quick jump spot. If there is one it should be red and marked. Good luck.
 

·
Registered
Joined
·
347 Posts
Is there a way to jump the car from the front under the hood somewhere?
Jim.
Yes, there are terminals for that purpose under the hood on the passenger side.
 

·
Premium Member
Joined
·
2,682 Posts
If your battery is leaking I would replace it anyway.

There could be multiple issues but one that came to mind when reading your post is the MyGig. It may have nothing to do with your lockpick but do you know if you need the flash for your nav? There's an issue with the nav freezing and staying on (the screen turns off but the rest of the nav and fan still run). I had this kill my battery a couple times before I brought it in for the update.

And like others said. Under the hood on the passenger side you will see the alternate terminals.
 

·
Registered
Joined
·
2,544 Posts
There is a RED cover over a terminal near the power distribution box on the right front corner. Ground to any good ground spot on the block. The dash indicators don't take much power to light up but it is the AMPERAGE you need to crank it over and start it.
 

·
Banned
Joined
·
7,566 Posts
I seem to remember some other members saying their battery drained after installing the lock pick. Search the site it was early last year.
 

·
Premium Member
Joined
·
3,546 Posts
I seem to remember some other members saying their battery drained after installing the lock pick. Search the site it was early last year.
From what I understand it's that the Lockpick or anything else that draws any current keeps the Buss from hybernating and keeps it drawing current. I've had a lock pick for 3 monthes and left my car without starting it for 3 days at a time and never had a problem starting it. I think the alarm draws more current than the Buss in standby.
 

·
Premium Member
Joined
·
2,994 Posts
On my 09, the draw from the battery with the car at rest and the alarm armed is about 30 mA (0.03 Amp). A good battery will be drained in 90 days or so. Alarm armed or disabled made no more than 5 mA difference as close as I could read with my meter.

I had a problem with the Trinity connected the CAN bus not going to sleep and the drain was major and it would have killed the battery in a day.
 

·
Registered
Joined
·
585 Posts
Discussion Starter #9
ok I found the problem!!!!! I took a good look at that neg post and when i went to wiggle it, it moved from side to side. I then tried to remove the nut and bolt that holds the clamp in place, but when i did, it just didsintegrated in my hands. The whole nut and bolt was eaten away. I tried to clean off the clamp but it didn't pay. I went to autozone, bought a new cable, cleaned up the battery post, and I was good to go. I think I just overtightened the clamp on the battery when i took it off to install the CAI back in june. Anyway I'm very excited that i'm back on the road and that I didn't have to remove that lockpick whew!!!! Thanks to all for ur help and input,
Jim
 

·
Registered
Joined
·
585 Posts
Discussion Starter #11
I really was worried about that lockpick, but thankfully that wasn't the problem. I do have a question for u though Itzrick. Did your lockpick come with a cd that was an update for the nav? If so did you install it. Mine did and I didnt install it yet, was wondering if its necessary to do so.
 

·
Premium Member
Joined
·
3,546 Posts
No I didn't get nav update and if it's a real nav update it will cost you a couple hundred $ if you install it. Now if your talking a software update, I did update my software to 2.302 and they are suppose to be releaseing 2.4 soon.
 

·
Registered
Joined
·
585 Posts
Discussion Starter #13
yes i believe its a software update disc that i got. How did you update your software? did you go to the dealer to do this? I havent updated my software since i got the car almost 2 years ago. Im guessing i should install this disc and see what happens.
 

·
Premium Member
Joined
·
3,546 Posts
Put the disc in and if it's good it will do everything it's self. It will propt you a couple times and ask if you want to do it and just say yes. Don't interupt it while it's doing it's thing. After you get done if you look at radio info the ver # will have changed. 2.302 the picture that shows up when you start the car won't be the RAM head any more but the new DODGE// emblem. You can download the software for free on line if you have a problem. I'm on every night if you need any help.
Rick
 

·
Registered
Joined
·
585 Posts
Discussion Starter #15
I'll mess with it tomorrow, thanks again for all your help pal. have a good night.
 
1 - 15 of 15 Posts
Top