Dodge Challenger Forum banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
260 Posts
Discussion Starter #1
I don't drive the car much. Dry day in the northwest for a change. Fire up the Chally first time in 2-3 weeks car started fine and warmed up nicely.

Turn car off get ready to leave and now for some reason the damn anti theft has kicked and and wont let me start the car.

The red security light is flashing and the normal key on sounds are very irratic and seem unstable.

Once I get the car started it wil idle for a minute and then die. If must be skimm key related.

Anyone elese have this happen? I hate to havve to tow in to the dealer, I have not been back since new and relay dont want to go in for service.

I only have 4100 miles on the clock since 11/08

Thanks
Bob
 

·
Premium Member
Joined
·
3,553 Posts
I never had this happen to me but all of this is computer ran. Allot of times you can hard reboot a computer and they work. You might unhook the battery for 60 sec or so and hook it back up and see what happens.
 

·
Premium Member
Joined
·
260 Posts
Discussion Starter #3
Ya I had the battery disconnected and charging for several hours. I finally got it stated took it around the block ran fine. turn it off and gremlins are still there. there is a pump or something that will cycle on and off and then in the odometer UPSWIFT will come on and off.

Maybe this is tipm related, damn.
 

·
Premium Member
Joined
·
260 Posts
Discussion Starter #4
I talked to a Dodge Tech and the winn module will need to be replaced under warranty.

Just an FYI
 

·
Premium Member
Joined
·
260 Posts
Discussion Starter #6
car has not been back for any service since day one. Bremerton dodge is no longer in business, so now I am asking for a referral from the guys in my area.

I spoke to a tech of a friend of mine down in Portland Oregon (150 miles away)

Parts should be only 1-2 days out if not in stock.
 

·
Premium Member
Joined
·
3,553 Posts
Sounds like that should be the same part they use in other cars so you should be OK. If it's like it is down here all dealer do more 300s and Chargers than anything else. Good luck finding a good dealer.
 

·
Premium Member
Joined
·
260 Posts
Discussion Starter #8
Got it towed to the dealer today. They say the pcm is dead, a new pcm will be here tomorrow. We shall see....
 

·
Registered
Joined
·
1,539 Posts
What caused the malfunction? Reconnecting the battery? That's bizarre and scary...lucky your car was just in the garage! I know whenever I took off the batt my ESP light would stay on, two full turns to the right and left with the wheel and it turned off, strange sequence disables in this car lol
 

·
Registered
Joined
·
1,399 Posts
Got it towed to the dealer today. They say the pcm is dead, a new pcm will be here tomorrow. We shall see....
Glad to see your dealer is taking care of you.

As you know most of us with 2009 SRT's are getting close to the end o our waranties, so, please let us know what the dealer may suspect could have caused this.

It sounds like this could have cost a few $$$ should your waranty had been up.:disgust::disgust:
 

·
Registered
Joined
·
2 Posts
I have a similar problem. I have a 2010 challenger SE. I started having trouble turning the car off then I was able to get it to turn off. It the mileage would stay lit up. And now a red light comes on and I can't get the car to turn on. Any idea what this could be?
 
1 - 11 of 11 Posts
Top