Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, I've noticed that one of my headlights stops/starts working randomly. Challenger Scat Pack 2017. When I open my car sometimes it doesn't work, but starts working after a few miles. Another time it works perfectly fine, but after few miles stops working. Once I noticed that another headlight also doesn't work, but that never happened again. What should I check? How can I check if my bulbs are fine with a multimeter? Thanks in advance!
 

·
Premium Member
Joined
·
4,062 Posts
Hi, I've noticed that one of my headlights stops/starts working randomly. Challenger Scat Pack 2017. When I open my car sometimes it doesn't work, but starts working after a few miles. Another time it works perfectly fine, but after few miles stops working. Once I noticed that another headlight also doesn't work, but that never happened again. What should I check? How can I check if my bulbs are fine with a multimeter? Thanks in advance!
Sounds like a loose/corroded connection. Vibration is breaking the insulator (corrosion) and making the connection. It's called a "make-break" issue. Get a can of electric connector cleaner. Inspect/clean all connections and try again. If that doesn't work, it is probably upstream and may require a tech to trouble shoot. Bulbs are either good or bad, That's not your issue. IMO
 

·
Premium Member
Joined
·
1,930 Posts
Hi, I've noticed that one of my headlights stops/starts working randomly. Challenger Scat Pack 2017. When I open my car sometimes it doesn't work, but starts working after a few miles. Another time it works perfectly fine, but after few miles stops working. Once I noticed that another headlight also doesn't work, but that never happened again. What should I check? How can I check if my bulbs are fine with a multimeter? Thanks in advance!
Hi CanisMajor,
Sorry to hear of the trouble you’re experiencing. If you decide to address this concern with your certified Dodge dealer, please feel free to send us a private message. We would be happy to provide you with an additional layer of assistance for that process.

Rob
Dodge Cares
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I've figured it out. Didn't expect that, cause it was working sometimes, but blown fuses was the reason. Changed them and now it's all right. Thanks for replies, case closed 💪
 

·
Premium Member
Joined
·
1,930 Posts
I've figured it out. Didn't expect that, cause it was working sometimes, but blown fuses was the reason. Changed them and now it's all right. Thanks for replies, case closed 💪
Hi CanisMajor,
We're happy to hear that your concern has been resolved! Should this or anything return in the future, please do not hesitate to reach out.

Rob
Dodge Cares
 
1 - 5 of 5 Posts
Top