Dodge Challenger Forum banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
5,645 Posts
Discussion Starter · #1 · (Edited)
The last 2 times I started my 14' SRT, the RPM took about 60 seconds to get into normal operating idle range (without me giving it gas). After start, idle was approx. 1350 RPM. Aftter a minute, settled to approx. 700-750 RPM

The car has 4750 total miles. It is not due for oil change until 7500 miles. Fluid levels look good. Both start ups were in my garage, on dry days, approx. 80F.

Has anyone experienced this?
 

·
Registered
Joined
·
178 Posts
I thought all cars did this when cold. I know mine does.
 

·
Premium Member
Joined
·
167 Posts
^^^^^ What DesertEagle said..
 

·
Premium Member
Joined
·
5,645 Posts
Discussion Starter · #4 ·
Mine would drop to 700 RPM within 15 seconds of startup...

Now it seems to lag.
 

·
Premium Member
Joined
·
3,087 Posts
15 seconds is about what both our 6.1L Hemi's take to drop to 750 RPM when it is 80F. When it is cold of course it takes longer. I did notice the other day when I had the battery disconnected, on first startup it took about a minute to settle and it hunted around some before lining out.
 
  • Like
Reactions: c26bt34c

·
Registered
2015 Scat Pack
Joined
·
2,321 Posts
After taking the catch can off of my r/t in preparation for trading the car in I forgot to hook the hoses back up (embarrassing I know). When I started the car up it stayed idling high.

Other than that it idles high when starting for a few seconds, much longer in the winter though when it's cold.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,075 Posts
The last 2 times I started my 14' SRT, the RPM took about 60 seconds to get into normal operating idle range (without me giving it gas). After start, idle was approx. 1350 RPM. Aftter a minute, settled to approx. 700-750 RPM

The car has 4750 total miles. It is not due for oil change until 7500 miles. Fluid levels look good. Both start ups were in my garage, on dry days, approx. 80F.

Has anyone experienced this?
Well, let's see, since December 20, 2007, when I bought my Charger R/T. My present car does the same thing.

Relax....
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top