Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2012 challenger R/T 5.7L manual and ive noticed high idle cold and hot, around 1,000 rpms. While driving I had my battery light come on. I figured its probably my subs pulling too much power but over never had this problem all 3 years of owning the car. Recently my car died on me. It was kind of an emergency so I bump started it and since then I have replaced the battery which solved the no start issue. Now I've notice parked or even making turns if I turn my wheel my abs light and traction control lights come on. Along with the whining I've already had, which I'm assuming is probably a bad/ going bad alternator. I dont seem to have performance issues but I'm afraid I'm going to have the same problem again or get stuck somewhere. Has anyone experienced this problem or have any insight on these issues?

Immediately after typing this my ac stopped blowing air and abs and traction control lights started going in and off, boe my car wont start just click. So new alternator it is..
 

·
Registered
2015 RT 5.7 M6
Joined
·
9,020 Posts
Yeah think there was a recall on some 2011 - 2014 challenger alternators with leaky diodes. Hopefully disconnecting the battery does not cause any issues with the WIN and/or BCM module. Lot's of pre-2015 guys post up not being able to start the car after a dead or removed battery.

Actually before buying an alternator check if your car has any open recalls.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Awesome, my car still needs the recall to be complete. Thank you for the help! I'll see if after that is replaced if that clears up some of the other issues.
 
1 - 3 of 3 Posts
Top