Dodge Challenger Forum banner

581 - 593 of 593 Posts

·
Registered
Joined
·
12 Posts
I'd want to say huge thanks to ChallyTatum from all those Ukrainian and Russian Challenger owners from drive2.ru who used translated instructions from this topic to activate STP and Launch control features!

idk if anyone has mentioned it but here's few things i learned during activating this on my Challenger:
1. Challenger SXT STP Chassis = 77 works fine
2. there's no need in an A\C module with STP button. method works with a stock one (but i changed mine anyways)
3. 2017 A\C module works on 2016 Challenger. but "Screen off" button won't work. still trying to figure it out
4. we don't need to kill the modem or antenna as there no compatible gsm towers in Europe
 

·
Registered
‘74 Duster 360 4M
Joined
·
628 Posts
3. 2017 A\C module works on 2016 Challenger. but "Screen off" button won't work. still trying to figure it out
I am betting you will need a 2017+ radio to make the screen off button work as I don’t think the 2016 and older radios have the function. But just a guess.
 
  • Like
Reactions: fonatig

·
Registered
Joined
·
12 Posts
crap. for some reason Perf. Control app isn't present on app screen anymore. i believe it happened after firmware update or chassis change.
i can still launch it with STP physical button. even though launch control works, drive mode setup switches aren't functional anymore.

has anyone had this issue?
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,841 Posts
Discussion Starter #585
Weird, I used to see an alert whenever someone posted in a thread I am following and now I don't. When I went to threads I am following there are quite a few new posts in some threads I am subscribed to but no alerts. And here I thought the forum traffic just slowed considerably.
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,841 Posts
Discussion Starter #586
crap. for some reason Perf. Control app isn't present on app screen anymore. i believe it happened after firmware update or chassis change.
i can still launch it with STP physical button. even though launch control works, drive mode setup switches aren't functional anymore.

has anyone had this issue?
Anytime the chassis type is changed you need to perform an initialization of the ABS module. Have you checked the BCM to make sure none of the values have changed?
 

·
Registered
Joined
·
12 Posts
Anytime the chassis type is changed you need to perform an initialization of the ABS module. Have you checked the BCM to make sure none of the values have changed?
yea, i did perform ABS initialization according the instructions

my BCM parameters look like this:

Performance Pages Present: Yes
Drive mode feature configuration: Yes
Memory drive mode sub-feature configuration: Yes
ESC drive mode sub-feature configuration: Yes
Super trac pack present: Yes
Chassis Type: Type 77 (was originally 44)

and i have tazer connected configured like this:

Set Sport Mode for 5 speed: NO
Set Sport Mode for 8 speed: YES
Set SRT Mode: NO
Set Performance Pages: YES
Set Super Track Pak: YES
Set Paddle Shifters: YES
Set Steering: NOT AVAILABLE
Set Drive Modes: SRT
Set Transmission Drive Mode: YES
Set Shift Light: NO
Set ECO mode: NO

maybe i'm missing something?
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,841 Posts
Discussion Starter #588
Ah, that might be your problem. There is no need to configure the settings with tazer once you do it with alfa. In fact, unmarry the tazer, make sure your settings have not changed with alfa (if so change them to what you had them to), then plug in the tazer but do not marry it (there is no need to).

BTW if you make changes to your BCM with alfa and the tazer married to the car it will undo all your changes when you unmarry it.

You don't have to have the tazer married to use line lock, light show, windows up/down with fob...it just needs to be plugged in.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,610 Posts
Welcome to Challengertalk ;)

A Guy
 
  • Like
Reactions: Bkgonefishin

·
Registered
2015 RT 5.7 M6
Joined
·
8,841 Posts
Discussion Starter #592
Here's a bcm read from a 2014 charger pursuit awd hemi.
Thanks. Has some interesting settings like ram truck wheel base and chassis type Type 5 /(SDW + BR6 + DJE).

BTW looks like you have some DTCs?
B2199
B1707
B170B
B16B3
B16AF
B16B7
 

·
Registered
Joined
·
2 Posts
Thanks. Has some interesting settings like ram truck wheel base and chassis type Type 5 /(SDW + BR6 + DJE).

BTW looks like you have some DTCs?
B2199
B1707
B170B
B16B3
B16AF
B16B7
Thanks for the help and warm welcome guys. I saw the DTCs. It has a bad cam and the battery is dead. I'm bidding on a rolled R/T Scat pack to get the motor and other accessories. Fingers crossed it doesn't go for a fortune.
 
581 - 593 of 593 Posts
Top