Dodge Challenger Forum banner

1 - 20 of 55 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
In-car race footage ----> 2014 POT O GOLD RUSH on Vimeo



Tough day at Road Atlanta today. It started out great. I led the race from turn 1. I started having shifter problems after about 5 laps. About the time I got the shifter sorted out and shifting good . I had a major engine failure that ended the race for me.It really stinks to break while running out front. I won't know how bad it is until I tear down the engine.
 

·
Registered
Joined
·
477 Posts
Love the front right wheel off the pavement, awesome! Sorry bout the DNF.
 

·
Registered
Joined
·
1,449 Posts
Dammit Man!! Nobody had anything for You. From what I have followed, that engine had held up well?
Thanks Joel, Good Luck this year.
 

·
Premium Member
09 RT Challenger auto
Joined
·
3,467 Posts
Ouch,!!!! That sucks.
What let loose,? Kick the bottom end out or something up like drop a valve.
Do you run into detnation issues any or have knk sensors shut off.
Good luck
FlatTop
 

·
Registered
Joined
·
1,840 Posts
That was a fun watch up to the end anyway. U certainly were movin. Hope it's not too bad
 

·
Premium Member
Joined
·
6,492 Posts
Ouch! You were doing great up until it let go. :( Hopefully it's not major work to fix and the block is salvageable. Busted piston/rings perhaps.
 

·
Registered
Joined
·
368 Posts
You were flying!!! Sorry to hear about the motor though. :(
 

·
Registered
Joined
·
1,265 Posts
Enjoyed watching your video, sorry about your motor. Hope you get her fixed up soon!
 

·
Registered
Joined
·
481 Posts
Awesome! What is the hose cooling?
 

·
Registered
Joined
·
56 Posts
SUCKS!!!

I logged on specifically looking to see if you were at RA last weekend. A couple of my CMC competitors drove down for the event (red/white Camaro, green Camaro).

good luck getting it fixed cheap!
 

·
Registered
Joined
·
119 Posts
Discussion Starter #18
The verdict is in. Valve stem broke on an intake valve. the locks were still in the valve retainer with the stem in place


I think the valve was sticking in the guide. I felt it miss for a few seconds going down the back straightaway a few laps before it broke.






[/url]
Photo100 by joelvandiver, on Flickr[/IMG]

[/url]
Photo099 by joelvandiver, on Flickr[/IMG]

[/url]
Photo101 by joelvandiver, on Flickr[/IMG]
 

·
Premium Member
Joined
·
6,492 Posts
Oh, snap!
 
1 - 20 of 55 Posts
Top