Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter #1
So right after buying my car which came with the Kenne Bell blower I went out and had a set of QTP cutouts installed. I a pair on my LSX Corvette and just LOVED the sound with a heads cam combo. I have put about 800 miles on the car over the past few months and EVERY time I open the cutouts the car feels slower. The boost doesn't seem to be accurate and honestly the sound while being loud is nothing like my Vette. Needless to say when I close the, and let Kenne Bell along with my Corsa cat back play a tune it sounds great and feels very smooth. After all my research I have come to the realization that my canned KB tune is not equipped to support cutouts and I am defeating the purpose. While they sound cool I think I will save them for the parking lot.
 
  • Like
Reactions: gasser and c26bt34c

·
Premium Member
Joined
·
5,645 Posts
That is where it counts...

On start up...in the lot.
 

·
Registered
Joined
·
252 Posts
Discussion Starter #3
I have no idea what the hell that means LOL
 

·
Registered
Joined
·
406 Posts
It's probably messing with the tune and throwing it off so that's why your car feels slower.
 

·
Registered
Joined
·
252 Posts
Discussion Starter #7
It is certainly messing with my tune. I had a Z06 with a fully built NA motor. I had cutouts on that car and picked up 8 rwhp on the dyno with them open. I am betting I lose about 30 rwhp in this car. LOL I guess I spent $800 to have a loud parking lot monster. HAHA
 

·
Registered
Joined
·
406 Posts
Could try getting it tuned with them open. It might be getting lean with them open. Who knows maybe it will end up making more power.
 
1 - 8 of 8 Posts
Top