Dodge Challenger Forum banner

1 - 20 of 25 Posts

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #1
Well I don't have a whole lot of info right now since all the parts are sitting at Crank This 380mi away... But I'm pretty excited so I figured I would at least get a thread ready.

Dropping it off this Friday

Build will include:
PWR 5.7 forged shortblock
2.8L Kenne Bell
DT Catless Headers
Blue Tops
SFI Flex Plate

Plan on only running around 8-12lbs for now.... still undecided...
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #2
Dropped off this morning.

Block came out





 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #4
Things are moving along..

block is in




running into the known issues of getting the 6.1 Kenne Bell kit to fit the Eagle 5.7





screwed up fitting




there was a bunch of water and oil in the blower




and it turns out Doug Thorley products are crap




but things are coming along. picked the right guy to do all the work

 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #5
fixed up fittings




and a now fitting front plate

before


after


 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #6
all came together after a good bit of work





 

·
Registered
Joined
·
21 Posts
AWESOME brother! Yup, you sure did pick the right guy to take care of your build..... let us know how you liked to end result on that drive home! :pimp:

We'll have to hook up and hit some M&Gs near home once my car is ready to hit some events.
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #8
For sure! Are you up in NoCal too? Would love to see your build.
 

·
Administrator
Joined
·
17,155 Posts
Your build is looking good. Keep posting your progress reports.
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #11
Just got it home.

Not a whole lot to report. Everything is running great!

Still haven't hit the dyno and we don't really know how much boost it's making so I can't get into it yet. The tune is scaled back like crazy to avoid any risk of detonation. Belt is also loosened to keep it from going into full boost by accident.

Will give more updates when it gets tuned.
 

·
Registered
Joined
·
1,879 Posts
Nice!!!! Hopefully you make well over 500rwhp. I need to do something to get mine up to 550-600rwhp. Got used to the KB and need MOAR!!!
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #14
uh oh



haven't really looked to see what its from yet... will tomorrow. have a feeling its related to the blower but that's still a little premature.
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #16
Yea I talked with cam about it. Two first things I'm checking are oil in the bellhousing and the oil separator for the KB. The drip was quick to pool like that but has stopped at the point you see above.
 

·
Registered
Joined
·
165 Posts
Holy crap that's a lot of oil Marty. Like we discussed and what Andy said, could be a a rear main, cam plug or the oil galley plugs. But to be honest, a leak that bad would have reared it's ugle head instantly. And every motor I do after startup goes up in the air running and everything is 100% inspected. And there was absolutely no signs of anything leaking. Plus in all the motors I done, never once have I had a leaker on these motors. Guess we'll see what happens there.

Considering that your catchcan was full, I still think it's the oil seperator that may be causing this. It's located directly above the bellhousing and oil could leak down around it and pool exactly where this is. Let me know what you find out after you pull the inspection cover. And whatever it is, we'll get it handled.
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #18
Cam, sent you a text. Pulled the plate this morning. I can feel some oil residue inside the housing but nothing even close to pooling.

It's still dripping a bit but since emptying the can it seems to have slowed greatly. Checked all around the separator but no oil. Couldn't feel back far enough to really check all the lines though.


Just keep an eye on the leak and oil levels until Bob is back?
 

·
Registered
Joined
·
165 Posts
Cam, sent you a text. Pulled the plate this morning. I can feel some oil residue inside the housing but nothing even close to pooling.

It's still dripping a bit but since emptying the can it seems to have slowed greatly. Checked all around the separator but no oil. Couldn't feel back far enough to really check all the lines though.


Just keep an eye on the leak and oil levels until Bob is back?
Some residue is very normal after assembly. If the leak where from the back of the motor, it'd pool inside the bell housing. It's got to be from a outside source. Also after looking at the pictures, I'm not dead certain it's oil.

So you guys understand what that means. His front end had been damaged in a accident and some of the tabs were busted off the fascia and the support. So under a time crunch and not wanting to spend another couple hours fixing it, I decided to screw the fascia to the front belly pan where a couple of the tabs were missing and get him down the road.

Well not only did I screw the plastic to the plastic, I screwed it plastic to plastic to intercooler. :icon_evil::icon_evil:

So after trying to find a replacement unit locally which didn't happen. I installed a stainless screw and that stopped the leak (it was very, very minor). And I also added some Bar's Leak to the system just incase. Did a couple hours worth of testing and it worked like a champ. I also gave Marty a substanial credit to purchase a new intercooler and find someone locally to install it for him.

Anyhow, Bar's leak makes the water look like mud, greazy mud. And I'm starting to think that it's got a leak at the back connection points to the intercooler located in the manifold.

Man ya gotta luv installing used crap. :(
 

·
Premium Member
Joined
·
2,682 Posts
Discussion Starter #20
Water levels have been staying fine... The leak and the Bars look similar but no way do they smell alike. Bars smells like **** and the leak smells like oil. Water levels are staying really constant too.

The two connections are on the back passenger side of the blower right? I didn't feel any oil back there.

If this helps at all... It appears most of the dripping is coming down the drivers side of the block but a little bit is coming down the opposite side.
 
1 - 20 of 25 Posts
Top