Dodge Challenger Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Has anyone seen this kind of problem on there instrument gauges. I have a 2010 Srt8 with about 70k miles and these black looking moisture spots came out of no where. Can any put there input on this? Thanks!
1015056
 

·
Registered
2016 R/T Scat Pack
Joined
·
1,534 Posts
YUP, had 6 failures in my old 2010 R/T, two were bad right out of the box. Thankfully I had extended warranty. It's an $800 job. The whole cluster has to be replaced.
 
  • Like
Reactions: 19johned53

·
Registered
2016 R/T Scat Pack
Joined
·
1,534 Posts
😣 thanks
Yeah it's a printed sheet, there are no bulbs to replace. Two of my failures also had the odomter, temp, gear position flickering in addition to the black spots :confused::mad:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·

·
Registered
2011 SXT Built in the Canada Plant
Joined
·
2,372 Posts

·
Registered
Furious Fuchsia 2010 Challenger R/T Classic A5
Joined
·
610 Posts
It's the EL (electroluminescent) foil built into the back of the cluster and needs to be fixed by professionals. If you remove the cluster and ship it off it's about a $250 dollar job which is only 1/3 the cost of a replacement unit.

For mine it seemed to get worse with the colder weather until I had it repaired by InstrumentClusterStore in PA. There was another highly regarded place in NY (the name is escaping me at this time) but they had a backlog of work at the time with a much longer wait.
 
1 - 9 of 9 Posts
Top