Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey All,
Own an '09 SRT8 6SPD and trying to diagnose an intermittent BAS/ESP that keeps popping UP and going away. Code in the ECM is a P0513.
WIN module was replaced by dealer last year because push start was not working. As well had to purchase new key fob and have it programmed, Note had to re mortgage the house to pay dealer for this :(.
All good until recently, had a second fob programmed by a lock specialist (dealer was too expensive). Now getting an intermittent BAS & ESP lights and P0513 code from ECM. Car starts and runs fine, removed push start and started/ran car with key. Same problem.
Appreciate any help, trying to avoid dealer at any cost.
 

·
Premium Member
The Pork Wagon (‘14 Cop Charger)
Joined
·
7,357 Posts
Hey All,
Own an '09 SRT8 6SPD and trying to diagnose an intermittent BAS/ESP that keeps popping UP and going away. Code in the ECM is a P0513.
WIN module was replaced by dealer last year because push start was not working. As well had to purchase new key fob and have it programmed, Note had to re mortgage the house to pay dealer for this :(.
All good until recently, had a second fob programmed by a lock specialist (dealer was too expensive). Now getting an intermittent BAS & ESP lights and P0513 code from ECM. Car starts and runs fine, removed push start and started/ran car with key. Same problem.
Appreciate any help, trying to avoid dealer at any cost.
I was under the impression that if you had an 2010 or older, you didn’t need the dealer to do the programming. Your experience seems to bear that out except for the P0513. Maybe they did it incorrectly?

I don’t know on this one. Is it possible to take the FOB back to the folks who did it and have them try again?
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
19,686 Posts
One note for the P0513 troubleshooting is

An external Radio-Frequency Identification (RFID) key (and/or pass/radio key), such as one used to gain access to a 24 hour gym, can cause this DTC to set and create a no start condition.

Just a thought. Go to Online Chilton Manual


2009> Dodge> Challenger> Repair> Type P0513

IGNITION KEY


NOTE
This DTC could have been set if the WIN harness connector was disconnected or if the WIN was replaced recently.


Not sure there is much an individual could do beyond clearing the code and seeing if that fixes it

A Guy
 
1 - 3 of 3 Posts
Top