Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1 (Edited)
Issues with U-Connect and Apple 4S I-Phones & Galaxy S4

We tried unsuccessfully to pair our newly purchased Samsong Galaxy S4 cell phones to the wife's RER radio in her 2010 Challenger, U-Connect support claimed Dodge only supported up to Version 2.0. The S4s are a higher version.

So we exchanged them for Apple 4S I-Phones. We paired them up and verified the cell phone contacts were transferred to the radio's phone book. But when using the radio phone button and saying "call ....", the response is " name not found, calling ......." and then a disconnect

I called U-Connect support and was told that Dodge only supported up to Version 5.0 which us about 2 yrs old. I-Phones are up to a version 7.1
I was told it was up to the cell phone companies to provide the updates, not Dodge to go asking for them.

Has anyone had any success with the I-Phones
Or from now on, will we have to buy cars based around what kind of cell phones we have ? :scratchhead:
 

·
Registered
Joined
·
102 Posts
That is crazy. I would install an aftermarket head-unit before going to an Apple phone. My S4 connects, but uConnect does have a problem dialing out and then disconnecting the session with the phone. Others have had the issue here, and I have had it with a DroidX and my S4 on 4.3 and 4.4 OS versions.

That being said, I have no problem with my several year old Sony aftermarket single DIN unit I put in my truck. Works with no issues on phone calls and has with all my phones through the years.
 

·
Registered
2015 Dodge Challenger SRT
Joined
·
748 Posts
My wife has no issues with connecting her '13 Charger R/T to her Apple iPhone 4.

And, I have no issue connecting my '11 Challenger R/T to my iPhone 5.

Both phones are fully updated.


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
4,364 Posts
My iPhone 4S works fine in my '13 RT Classic 430N unit.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
All's well now . I was told by U-connect support people that I needed 1 update, and they were going to send me a disc. That was around 4/14. I still haven't received it ! But that doesn't matter anymore.
Wife took the car in for service,and while there she asked them if they could do the update. They found a total of 7 updates needed. After they were done, every thing works fine.
 
1 - 5 of 5 Posts
Top