Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 12 of 12 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Installed my stealthbox about a month ago with an jl audio rd900 watt 5 channel amp . 1st month it sounded amazing even though some songs you only heard the inside speakers and no bass from the sub at all or minimum. I don't know if I need to tweak the settings on my amp but after another month im starting to notice the bass is separated and so obvious to catch. Some songs the low bass sounds amazing ! Others the its sounds so bad you have to change the song because it just doesn't sound rite or as if its in sync. Sound like the its struggle to catch the bass or the type of bass just doesn't sound well. I have had systems and every song I played sounded amazing. Also have a few friends that rock systems in other vehicles and same songs don't sound terrible or distorted as if it its not synced correctly so any help on updating amp or what would be appreciated. I also noticed my bass knob is turned all the way up so I don't know how my it was set up . In a friend of mine vehicle his stuff sounds with more bass as I turn the knob and volume up . My stuff all the way up from the get go and so confused about that as well
 

·
Registered
Joined
·
224 Posts
Do you have a picture or details of all your settings? Cross over, gain?
Where are you getting you sub signal? Speaker Level? If so, what speakers did you tap?
Or are you using a line level converter? If so, what is the output set to at 80% max volume (stereo volume).
Are you using all 5 channels?
What other speakers are you driving?
What are their settings?
I have a 15” Sundown SA-15 with a 1000W Sundown amp (AudioControl LOC) that sounded great. Then I added CDT 6x9s in the front doors driven with 100W each. Since the door speakers play frequencies lower than ~250-300Hz (and are now amplified much more than stock) it seemed as if the door speakers were canceling out the subwoofer (out of phase), more noticeable on certain songs.
I set the door speaker crossover to 100Hz High Pass and it is back to sounding great again, both bass and mid bass. I also have JBL 3.5s in dash and rear doors (driven by stock Alpine amp) and removed the stock 6x9s and 8” from rear deck (didn’t want rear fill).
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Off the top of my head I have the jl audio stealth box and I am powering door and back speakers . Using the audio control loc. I havent seen the gains yet to see where it's set at but I wanted to reach out to see if thats where I need to look at first. That's technical beyond my knowledge tbh so let me get a picture and I will post by tomorrow morning
 

·
Registered
Joined
·
224 Posts
1. JL Low Level input is 2V max
To set gains properly
Disconnect sub from LOC
Set stereo volume to 80% of max
Play 50Hz test done using a CD
Adjust LOC gain until output is 2V with multi-meter
Connect LOC to Sub
Adjust crossover to 80Hz
Play 50Hz test tone gain at 80% volume
increase gain until output of amp is ~31.6V assuming you have a 2ohm sub.
Power = V^2 / R
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,439 Posts
What is the source/quality of the tracks being played. I’ve noticed some sources like internet streams (especially over a Bluetooth connection) won’t sound good no matter how I adjust the system.
 
  • Like
Reactions: Story

·
Registered
Joined
·
23 Posts
Discussion Starter · #6 ·
I use tidal and it's pretty much consistent through the tracks. Also have played same tracks in another system and despite it being more subs and power its all sounds in sync .
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,439 Posts
I use tidal and it's pretty much consistent through the tracks. Also have played same tracks in another system and despite it being more subs and power its all sounds in sync .
Im not familiar with Tidal, but I’ll trust you on it. What about the back seat? Is all this occurring with both back seats in the upright position?

Those seat backs absorb a lot of bass energy. I pretty much leave the passenger seat back folded down now unless I have a passenger back there. That elevates the sound of the trunk mounted sub by at least 75% in my particular setup.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
Its a streaming service for music but I play it via Bluetooth. Im going to check it but trunk was shaking when I turned it up to 19 however inside you can hear the out of sync. Bass that I hear on some songs. It banged but felt forced instead if a natural flow of bass
 

·
Registered
Joined
·
6 Posts
These cars absolutely suck with audio in the trunk. I have over $2k on my audio and on a regular car you can get the same sound for half the price.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,439 Posts
Its a streaming service for music but I play it via Bluetooth. Im going to check it but trunk was shaking when I turned it up to 19 however inside you can hear the out of sync. Bass that I hear on some songs. It banged but felt forced instead if a natural flow of bass
have you tried swapping the + and - wires on the sub to see if it’s a phase issue?
 

·
Registered
Joined
·
224 Posts
Also try disconnecting the rear speakers connected to the amp. Usually systems will sound better with front stage only and sub in the rear.
 
1 - 12 of 12 Posts
Top