Dodge Challenger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
So in my 5 month old 2017 Scat Pack Shaker the keyless enter and go system stopped working properly. The car is stock, no mods. When I put my hand under the handle it no longer unlocks every time. I have to be right next to the vehicle to lock, unlock, or use the remote start features on the keyfob. Even then, I often have to use multiple button presses to get it to work. I have found that occasionally keyless will work if I point the keyfob just right towards the console with the fob right next to the window. That doesn't work every time either. It also fails to detect the keyfob while trying to start the vehicle. I have to press the keyfob to the start button to start. Again if I point the key fob just right I will occasionally be able to start with a finger press, but that is not predictable either.

I've tried both keyfobs and replaced both keyfob batteries with no change. I guess it's time to let the local Dodge Service Center look it over. I found other threads that had keyfob issues, but not on a newer challenger and most of the others seemed to resolve the issue with a battery change. Has anyone else seen symptoms like mine?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Took the car to the dealer and showed the service advisor the issue. So far the dealer hasn't fixed it. Claimed the tech had difficulty repeating the issue. Took it home for now, but plan to take it back. Does anyone know where I can find the RF antenna(s) that is used by the keyless system?
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,912 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #5 (Edited)
Thanks Guy. I don't think they did anything other than walk up to it and press the button on the keyfob. I will check out that thread you linked and maybe disconnect the battery myself. I'm a little pissed off at the dealer at the moment for not doing much of anything. The service advisor had the audacity to tell me that he's seen tint cause this issue. I said okay, well the tint came with the car. And the car has been working fine for 5 months. So it's not the tint.

Perhaps I need to explain the problem as being one of operating at the proper range, since the system does seem to work if I take the keys out of my pocket and point them right at the center console, just about touching my window. Even that method only works some of the time. The button functions on the keyfob for locking and unlocking the doors should work much further away, somewhere in the area of 50ft. They only work when I'm within 3 feet or less of the vehicle. That doesn't sound like working properly to me.
 

·
Super Moderator
Joined
·
15,381 Posts
there's multiple receivers for the Keyless Go - clearly yours doesn't have the correct operating range.

Since you've changed batteries and that didn't help, they need to delve further into it...mine is sensitive that I just brush my fingers on the underside of the door handles and it responds.

I used to wash the car with the fob clipped to my belt loop, but washing the handles made them go nuts, so I hang the fob and the far end of the garage, out of range.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #7
Thanks Hal! I've noticed the same thing when cleaning the handles if I have the keys in my pocket. I tend to go around those quickly or avoid them. Now it doesn't unlock, so not as big of a deal. The instrument cluster still turns on when I put my hand under the handle though, that tells me the handle sensor works fine, the car is just not communicating well with the keyfob to verify it can unlock the door.

I made an appointment to bring the car back. I plan to speak with them specifically about checking on the antenna connections. I bet one of the antenna connections got jostled loose when I folded the rear seats down a few weeks ago.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
Quick update. Took the car to the dealer today. They ran some diagnostics on it but saw no red flags. They decided to try and sync a new set of keyfobs to the vehicle to see if that solved the problem. The new keyfobs had the same range issue that the old ones did. At this point they opened a STAR case with FCA. As much as I hated to leave it, the car is now at the dealer and they gave me a loaner car, (Jeep Cherokee actually). Hopefully they find a resolution soon. I still wonder if they even tried to look for the RF Antenna module(s) to see if it was as simple as a loose connection.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #9
Problem solved! Got the car back earlier today. The dealer first replaced 2 RF antennas. That didn't solve the range issue. Next they replaced a module related to Remote Start. After replacing that module, the keyless entry system began acting normal again. I'm very happy to have my challenger back and fully functional again!
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,912 Posts
Awesome :thumbsup:

A Guy
 
1 - 11 of 11 Posts
Top