Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1,123 Posts
Sounds like its missing a diode somewhere
 

·
Premium Member
Joined
·
280 Posts
I had nothing but trouble with switch backs. Either they would randomly hyper blink after 6 clicks of regular clicks on the passenger, or the whites would (one at a time) turn off and stay off leaving the car winking (swap sides, white stayed off, to then the whites would come on and turn off randomly when they felt like it. I got sick of them after so much money spent on bulbs and resistors from different manufacturers, I just did the full fog to turn signal conversion making the centers JUST turn on from the fog button and my fogs blink retro style. Use regular white led bulbs in those and 3156 (used a home made adapter to turn the fog wires to accept 3156) in the centers. Been going perfect for 3 months now.
 

·
Registered
Joined
·
2,463 Posts
Sounds like wrong resistors, you need a 6ohm 50watt resistor for each side front, spliced between the turn/ground wire and 3ohm 50 watt resistors each side on rear (two bulb resistors) again spliced between ground/turn brake wires. If you got the White On switchbacks I don't know why it's doing that if NOT resistors as I use White OFF on mine, seemed simpler so that may also be your problem but with all flashing my BET is your resistors are not wired correctly. S
 
1 - 5 of 5 Posts
Top