Dodge Challenger Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
I have a 2015 Challenger RT and about 3k on it. I hear some lifter tapping going on, is that normal? Ive been told that all 5.7L Hemi's do that. Still not a sound that Im comfortable with. Any ideas how to stop the tapping? I changed the oil at 800 miles to 5w20 Mobil1 extended performance and Fram 15k Ultra synthetic filter. I do race the car but don't hit rev limiter like armatures. It is a 6-spd stick. No mods...yet. before I get into it I would like to know if this is a problem to have fixed first, and is it a warranty liable issue? Any advice would be great. Thanks.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #2
I forgot to mention, I didn't start racing at the strip till I had 1.5k miles on the car, so it was properly broke in.
 

·
Registered
Joined
·
14 Posts
I too have a 15 rt shaker 5.7 and the noise is terrible. Have 3000 miles on it and yesterday I took her in for an oil change and to check the tap. The mechanic said it was normal and I asked to hear another rt on the lot. I go the whole "it close to closing time" blah blah blah.... I'll be going back on Monday as I'm not comfortable paying 35000 for a car that sounds like a 1980s Toyota Corolla!
 

·
Registered
Joined
·
43 Posts
Discussion Starter #4
Ok, yes please do, I caught the same dealer BS too. I know they do make a tapping noise but for it to be noticeable and not go away bothers me when I shelled out 35k for the car.
 

·
Registered
Joined
·
14,078 Posts
There seems to be thousands of posts here of people saying their car ticks and the dealer usually says it's normal. My engine does not tick but will occasionally get the sewing machine sound which I assume is a lifter clatter sound from all the lifters. It occurs from about 1800 to 2200 rpm and is totally random when it will happen. Usually it's quiet. A constant tick to me says the engine has a problem with one lifter or valve and that should be fixed. Not sure what to do about the occasional clatter.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
Mine is a consistent tick, and its only at low RPM's, like 1500 or less when I notice it, I probably would hear it at higher RPM's but I cut off the stock mufflers and ran pipe, kept the factory cats and resonators. So above 1500RPM it gets louder than the tick.
 

·
Registered
Joined
·
781 Posts
This is a commonly known issue. Unfortunately, dodge refuses to do anything about it since it is not a safety issue. I have had my lifters replaced twice to no avail. Hopefully one day they will step up and fix it, but I highly doubt it. For now, we just have to live with it, drive it hard until the warranty is almost up, then trade it in. Bummer...
 

·
Registered
Joined
·
14 Posts
Took it back to the dealer and they said it's the fuel injectors. My answer to them was "Well, change the injectors then!" They said it's normal.

So dodge means to tell me that a brand new car should sound like a diesel truck breaking down? I'm going to try to contact Dodge corporate cause this is bullsh1t.
 

·
Registered
Joined
·
72 Posts
Mine has done it since day one. It has 1800 miles on it and is 11 months old. Had the oil changed at 500 miles. I have done a resonator delete so now I can't hear it.
 

·
Premium Member
Joined
·
6,492 Posts
Welcome to the "HEMI tick" club. ;) Some engines do it, some don't. My '11 was super quiet, never any ticking and I ran either Mobil 1 5w20 or Royal Purple 5w20. Running Pennzoil did make the engine noisier overall, but I never had a problem with the tick.

It may be annoying, but it's not a "problem." The HEMI engines go forever, tick or no tick. I've never seen any failure that could be linked back to the tick. If it's the injectors, you may want to try running some Chevron Techron Fuel System Concentrate (thick, black bottle) through a tank of fuel and see if that helps. I did that every 3000-4000 miles and always experienced an improvement in overall engine smoothness when I'd do it.
 

·
Registered
Joined
·
41 Posts
I have a 2015 and it ticks a little all the time. I do get valve chatter when loafing around when I buy cheap gas. I ran a tank of chevron premium and got no chatter at all. Ticking slight but still there. My wife had a 2006 hemi durango and it ticked. We put 60k on it with no issues at all. A friend has over 130k on his hemi magnum r/t and no worries at all!!!


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
72 Posts
My 2015 rt+ STP with 9,000 miles is a pos, should have kept my 2012 Camaro convertible. Why...

Door panels become loose constantly so it vibrates with music or road bumps, (two shop visits) on going issue even after door replaced
Constant squeezing in the right front wheel like a bat chattering (on second visit now got a damn dart rental (I'm 6'3 280,)
On the way to the shop the electronic throttle control goes out and flashes like a hyper strobe light between the warning and my current speed on the console. Engine (at 38 mph down shifts to first and I pull over bs push the break to the floor.. Damn car still fighting me to go I put the car in park and it starts to slowly rev higher I turn off the car "punish" the steering wheel a few times and tried to start it back up. Car wouldn't shift out of first in auto on manual mode I could shift but the M1 flashed constantly (even when out of first) anyone else suffer like this,


Billet is the color of a cold colt 45 ..
 

·
Registered
2017 T/A 5.7 A8 front and rear strut braces frame connectors
Joined
·
1,216 Posts
i have a 2014 5.7 i had lifter tap twice when i first started the car.i was using fram filter and didnt drive the car everyday.i swapped over to a factory srt oil filter and have had no problem since(i do get the sewing machine sound at times)the fram filter was draining back down while the car sat i am guessing
 

·
Registered
Joined
·
744 Posts
That is still early to be racing it in my opinion.You are not getting full performance as computer does not unlock variable valve timing until 3750 miles.My 2014 RT seemed slow until about 4000-5000 miles then it "woke up".Everything I have read says these engines are tight and need to loosen up a bit before hammering them.I have heard Amsol synthetic oil quiets these engines down quite a bit.My 2014 had the tick but it ran like a champ.I just traded it in on a 2015 Sublime R/T that I will baby until it has at least 4000 miles on it.
 

·
Registered
Joined
·
3 Posts
My 2015 rt+ STP with 9,000 miles is a pos, should have kept my 2012 Camaro convertible. Why...

Door panels become loose constantly so it vibrates with music or road bumps, (two shop visits) on going issue even after door replaced
Constant squeezing in the right front wheel like a bat chattering (on second visit now got a damn dart rental (I'm 6'3 280,)
On the way to the shop the electronic throttle control goes out and flashes like a hyper strobe light between the warning and my current speed on the console. Engine (at 38 mph down shifts to first and I pull over bs push the break to the floor.. Damn car still fighting me to go I put the car in park and it starts to slowly rev higher I turn off the car "punish" the steering wheel a few times and tried to start it back up. Car wouldn't shift out of first in auto on manual mode I could shift but the M1 flashed constantly (even when out of first) anyone else suffer like this,


Billet is the color of a cold colt 45 ..
Bro sounds like you got your self s lemon.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
15,759 Posts
5 year old lemon now, lol

A Guy
 

·
Registered
2010 Furious Fuchsia SRT8 . 57/400
Joined
·
12 Posts
I have a 2015 Challenger RT and about 3k on it. I hear some lifter tapping going on, is that normal? Ive been told that all 5.7L Hemi's do that. Still not a sound that Im comfortable with. Any ideas how to stop the tapping? I changed the oil at 800 miles to 5w20 Mobil1 extended performance and Fram 15k Ultra synthetic filter. I do race the car but don't hit rev limiter like armatures. It is a 6-spd stick. No mods...yet. before I get into it I would like to know if this is a problem to have fixed first, and is it a warranty liable issue? Any advice would be great. Thanks.
Mine does that sometimes and I put some marvel mystery oil ...like 1/2 cup into the case, you may need to extract some oil first as not to over fill it causing seals to become compromised or blow...take a long like fish tank cleat hose that fits down the dip stick shaft..get one of those bg syringes that will fit into the hose if its not air tight put a clamp on it to make it seal up tight then start to pull the plunger up until you see oil coming make sure hose can reach into a vessel enough for 1/2 cup is all...then put the marvel mystery oil in the oil fill and go give her a run..I bet it makes it go right away. good luck
 
1 - 19 of 19 Posts
Top