Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey Mopar Enthusiasts!

I've read Challenger Talk many times and decided that I really just need to join the conversations!

Recently I've come across an issue that I'm not sure how to approach. Bringing in to the dealer is probably an easy solution, but honestly haven't made the appointment yet. I was hoping someone on here can help?

When accessing the driver mode set-up, the sport mode will not engage. On the touch screen, I can switch it to sport mode, but it will switch itself back and will not stay. It does not feel as if the car is making that switch, even when it briefly indicates it's in sport mode.

I've looked online and found that resetting the uconnect to factory settings has helped a number of electronic issues. I wasn't sure if this is something I should try or just bring it to the dealer?

Thoughts? Thanks!
 

·
Banned
2016 R/T Scat Pack
Joined
·
3,889 Posts
Hey Mopar Enthusiasts!

I've read Challenger Talk many times and decided that I really just need to join the conversations!

Recently I've come across an issue that I'm not sure how to approach. Bringing in to the dealer is probably an easy solution, but honestly haven't made the appointment yet. I was hoping someone on here can help?

When accessing the driver mode set-up, the sport mode will not engage. On the touch screen, I can switch it to sport mode, but it will switch itself back and will not stay. It does not feel as if the car is making that switch, even when it briefly indicates it's in sport mode.

I've looked online and found that resetting the uconnect to factory settings has helped a number of electronic issues. I wasn't sure if this is something I should try or just bring it to the dealer?

Thoughts? Thanks!
http://www.challengertalk.com/forums/f188/sport-mode-not-working-after-software-upgrade-587722/
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
17,064 Posts
Welcome from California ;)

A Guy
 

·
Premium Member
Joined
·
2,874 Posts
Welcome and good luck. Let us know how you do, you are not alone.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks all for the welcome! And PraiseV8, thanks for the link, if definitely helped. I've spent a few hours getting caught up on this OTA update issue. I hope a resolution comes soon!
 
1 - 7 of 7 Posts
Top