Dodge Challenger Forum banner

21 - 40 of 49 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #21
2012 rt with with 126000 on the clock..also when i start it up and its already been drivin or warmed up it goes up to about 2000 or 2200 rpms and then comes down slow..didnt go up like that before but the engine light is still on when i drive it..so might need to get it scanned maybe???
Also dont know what that red light is or means next to the seatbelt light????
 

·
Registered
Joined
·
196 Posts
Discussion Starter #22
Just opened hood to check sensor and wire to the throttle body???? And seen this...looks like thw air tube cracked and came apart so there is a huge gap there to suck air threw..could this be my problem??? 20200629_091806.jpg
 

·
Super Moderator
Joined
·
15,564 Posts
you need it scanned to see what codes are present.

The ESP and traction control indicate potentially an issue with one or more ABS sensors

if electrical voltage level is too low, it will create several errors in the system

if there's issues with the transmission, then its a matter of sorting that out
- if there's a solenoid that is intermittent or a check valve sticking or leading that can trigger limp modes as well

the lights alone aren't a way to diagnose the problem. Scanning for codes and troubleshooting is the way you do it
 

·
Super Moderator
Joined
·
15,564 Posts
Just opened hood to check sensor and wire to the throttle body???? And seen this...looks like thw air tube cracked and came apart so there is a huge gap there to suck air threw..could this be my problem??? View attachment 997036
its certainly time to replace that - you're getting unfiltered air into the engine.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #25
its certainly time to replace that - you're getting unfiltered air into the engine.
Yes indeed!!! Trying to find a place that has one in stock now? But i am going to get that replaced and get a scan done on it..is auto parts store ok to have them hook up to see what codes it gives me??? Or dealer??
 

·
Registered
Joined
·
196 Posts
Discussion Starter #26
its certainly time to replace that - you're getting unfiltered air into the engine.
ok guess i have to search online for the air tube..cant oder one anywheres...also these codes came back...im guessing the air tube from the throttle body to the air box is the cause...hell i can stick my fingers into the opening....here is pic of readout 15934438490408356310498304440918.jpg
 

·
Premium Member
The Pork Wagon (‘14 Cop Charger)
Joined
·
6,528 Posts
Just opened hood to check sensor and wire to the throttle body???? And seen this...looks like thw air tube cracked and came apart so there is a huge gap there to suck air threw..could this be my problem??? View attachment 997036
If that ain’t the problem, it’ll do until you find it. Get that replaced ASAP and then reset everything, and take for another test drive.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #28
If that ain’t the problem, it’ll do until you find it. Get that replaced ASAP and then reset everything, and take for another test drive.
Thanks nuke...gonna retape this one untill i find one..auto parts stores cant order it..what a crock of shit..so need to find one online...did ya see the readout of my car..burning lean on bank 1 and 2...thinking thays the reason..but either way im ordering the new tube for it today...then go from there..
 

·
Premium Member
The Pork Wagon (‘14 Cop Charger)
Joined
·
6,528 Posts
Any ideas or sites to look at???
What Year model is the engine? Or take a pic of the whole intake tube so I can see its shape.

I have an OE intake tube and filter box that came off my 2012 (or was it the one from the 2014...doesn’t matter, they are identical) that you can have if it will fit.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #31
Omg...that was the problem...i duck taped it up as good as possible disconnected my battery to reset everything and now it runs just fine with no lights on at all....
 

·
Registered
Joined
·
196 Posts
Discussion Starter #32
Doea it have the silencer on it Nuke?? If so il need to buy the one without so i can put on my catch can and mount it where the silencer rests..dont really need it ive been told on the rt,s but looks good being there lol plus i bought it before i knew..mine is a 2012 rt 5.7 auto 20200629_125133_HDR.jpg 20200629_125139.jpg
 

·
Registered
Joined
·
360 Posts
Doea it have the silencer on it Nuke?? If so il need to buy the one without so i can put on my catch can and mount it where the silencer rests..dont really need it ive been told on the rt,s but looks good being there lol plus i bought it before i knew..mine is a 2012 rt 5.7 auto View attachment 997041 View attachment 997042
The tube for the Charger fits and it doesn't have the silencer on it.


Also in the future you can get the codes yourself by doing what was called the key dance for 2014 and earlier.
If you have push button start, pop out the button and insert your key in the slot. Without starting the car, turn the key to the 'ACC' position, then turn it to 'RUN', then back to 'ACC', then to 'RUN', then back to 'ACC', then to 'RUN', the codes will display in your EVIC.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #34
Thanks RoadTrippin' for the info and part number...also for the way to check codes myaelf good info..thanks for passing it on
 

·
Registered
Joined
·
196 Posts
Discussion Starter #35
Also was wondering of it is better or nicer to have the push button in or out??? Ive heard they are a pain??mine came with just the key and no push start button..was thinking of buying one for it of they are not a pain...then ya just need to carry your keyfobe with ya??
 

·
Registered
Joined
·
360 Posts
Not all cars came with the push button start, you should be able to check by using your finger to press as long as the keyfob is in the car, if it starts, buy the button.
With my '14, the only time my keys come out of my pocket is to open the door to my house. :)

I've found no time that it was a pain for me in the last six years.
 

·
Premium Member
The Pork Wagon (‘14 Cop Charger)
Joined
·
6,528 Posts

·
Registered
Joined
·
621 Posts
Dont waste $$ by throwing parts at it. Scan the car, pcm, abs, bcm, tcm. Complete car. Otherwise your just guessing and not doing any good. It could be simple fix or expensive, but without scanning first your wasting $$ if you buy anything.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #40
Not all cars came with the push button start, you should be able to check by using your finger to press as long as the keyfob is in the car, if it starts, buy the button.
With my '14, the only time my keys come out of my pocket is to open the door to my house. :)

I've found no time that it was a pain for me in the last six years.
Thanks RoadTrippin' yea i have started it with my finger with keyfob in pocket..so looks like im gonna be getting me a push button...thanks....also i love the lock and unlock feature...walk away the doors lock walk up on it and touch the small button on top of door handle and they unlock..so now il be able to jist keep the keyfob in pocket...hell yea!!
 
21 - 40 of 49 Posts
Top