Dodge Challenger Forum banner

1 - 20 of 48 Posts

·
Banned
Joined
·
7,566 Posts
Discussion Starter #1 (Edited)
Edited 12/6/2010 to add - I've had the gauge plugged up for about 5 days without starting the car. Battery still shows 12.3 volts. This issue is resolved!

-------------------------------------------------------------------------------------------------------------------------------------

I sent my Interceptor in to Aeroforce for the code flash update to fix the battery drain issue when connected to OBDII power. I got the gauge back last week and have had it plugged in to my car for 3 days without starting the car.

I checked the battery with a DMM this morning and it's still at 12.37V. Previously it would have already been down in the 11V range after a day or two if I didn't unplug the gauge from the OBDII port.

If you were holding off on one of these, I think it's safe to say they licked the issue.

Anyone else who sent there's in chime and and lemme know what you're seeing.

Now for the OCD part - Aeroforce sent me one of their gauges by mistake and it had a white readout vs. the blue I had. They sent me an e-mail stating the mistake and overnighted my blue gauge and told me I could pick the one I wanted and they'd pay to send the other back. Well, I ended up liking the white readout a bit better so now I've ordered an Autometer boost gauge to match to replace my blue Autometer C2 gauge..

Anyone wanna buy an Autometer C2 boost gauge? It'll be in the box as new with everything included as new. I'm just swapping the gauges in my car.
 

·
Banned
Joined
·
7,566 Posts
Discussion Starter #3
lets see the white readout
I've gotta head back to work here in a bit (worked till 3am last night).

I'll snag a pic or two here soon. My matching boost gauge should be here Monday. I'll throw that in and get some good pics.
 
Joined
·
5,134 Posts
Good to see this is fixed. Their customer support looks top notch.
 

·
Premium Member
Joined
·
5,634 Posts
Speedy is it safe order a gauge now?? I am serious I want to get one.
 

·
Banned
Joined
·
7,566 Posts
Discussion Starter #6
Speedy is it safe order a gauge now?? I am serious I want to get one.
Looks to be. If you want to wait a few more days I plan to keep checking the battery to be absolutely sure. If the battery stays above 12V another 2 days I'd say it's fixed 100%.

Here's a picture of the white read out. I had a few minutes before heading to work and took these real quick.

I chose the Mopar logo for the boot up screen.


Obviously the car's not running but here's ignition advance and AFR.


Here's the boost gauge I'm gonna use to match:



The Interceptor is customizable with different face colors. I'm gonna put the black on it to see how it looks compared to the white.

Here's what I had in the car - the blue:

 

·
Premium Member
Joined
·
1,949 Posts
I like the newer one better as well. Goes with the trim better.
 

·
Banned
Joined
·
7,566 Posts
Discussion Starter #8
I like the newer one better as well. Goes with the trim better.
I liked the blue as well, but had an opportunity to change up, so I went for it.

I'm anxious to see how it looks with both black face gauges installed.

I also had Aeroforce drop in a fuel pressure sensor in the box when they mailed my gauge back. Now I can see fuel pressure at the rail or on the Interceptor while driving.
 

·
Premium Member
Joined
·
1,949 Posts
speedy what size injectors do you run?
 

·
Premium Member
Joined
·
686 Posts
really like the look of the new guages.
I did like the blue but believe i would change too after seeing these.
 

·
Banned
Joined
·
4,698 Posts
The blue with the black faces (I have dual gauges) are the cat's azz! You going with black now, hmmmmm???? Good taste! I have the same white R/T faces as Speedy, but when I put the black on, the wife looked at me and said those look mean....she's right ;-)

George - the data kicks butt. I've got the fuel pressure sensor. The only problem with it is if you unplug the gauge at the OBD2...say if you want to datalog or you tuner is in there, it'll blow the fuel pressure sensor. Be careful with that, J!!!

HemiSam
 

·
Banned
Joined
·
7,566 Posts
Discussion Starter #13
I've got the fuel pressure sensor. The only problem with it is if you unplug the gauge at the OBD2...say if you want to datalog or you tuner is in there, it'll blow the fuel pressure sensor. Be careful with that, J!!!

HemiSam
Yeah I read that in the instructions. I believe it's due to the 5V regulated output power adapter, otherwise known as the illudium P32 space modulator.
 

·
Banned
Joined
·
7,566 Posts
Discussion Starter #15
OK. Had the gauge hooked up about 5 days and haven't started the car. Battery still reads 12.3V. All's well so order away BuckWheat.
 

·
Vendor
Joined
·
5,673 Posts
Thanks for helping test that Speedy and we're also excited for the fix!! If anyone wants Aeroforce or has questions, give us a call 888-SPD-LOGX. :)
 

·
Banned
Joined
·
4,698 Posts
What about the functionality, J? Mine was going weird when I used the annunciators. You drive it much yet to check out any reboot issues, etc...?

I can't wait to get my dual gauge setup back. Due in tomorrow, I think.

HemiSam
 

·
Premium Member
2016 Challenger Hellcat, Plum Crazy Purple, A8 (Grape Ape)
Joined
·
3,601 Posts
Yep, Speedy is right. I have had mine back for a few weeks. Works great! I had the timeout set to 5 sec and it drained the battery. Todd got me straight and it's set for the 30 sec delay with no issues now. It takes a while to come on after start up but no resets or battery drain.
 

·
Banned
Joined
·
4,698 Posts
Cool. Mine did take a while to boot up when I left them plugged into the OBD2 after shutting off the car. Funny thing is they start right up if you plug them in after the car is started...

HemiSam
 
1 - 20 of 48 Posts
Top