Dodge Challenger Forum banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
2,172 Posts
Discussion Starter #1
I just put on a New set of 4 goodyear tires.
The low presure light started to blink on and off for a few mins and then stayed on
I add a tad of air to each tire but no luck
Tire is at 40
I just thought it should have reseted on its own by now(3 days}
What do you folks think the problem is?I hate to drive back to the tire store 30 mins away...........................JQ
 

·
Premium Member
Joined
·
3,546 Posts
I don't know how far you drove after the pressure was up were it should be but it needs driven. The # of days won't reset it.
 

·
Premium Member
Joined
·
2,172 Posts
Discussion Starter #4
Well from the Tire store was 15 miles till the light came on
The next day I added a tad of Air and maybe drove a few miles (5 miles}
Today its the same story about 5 miles........

I know with my Old tires that came with the car,when the low presure
light would come on I would add a tad of air and within mins the light would go off.

I just think that the light should not take about 2 or3 days..Thanks............JQ
 

·
Registered
Joined
·
683 Posts
Who put the tires on? Do you hear any clicking noises when you drive very slowly? The TPMS sensor could have fallen into the tire. Or they could have damaged it.
 

·
Registered
Joined
·
389 Posts
If you drove 30 mins from the tire shop, the TPMS should have reset. The light shouldn't go off unless you're below 28 lbs PSI. The flashing light could be an indication of a couple of possibilities...

If the TPMS from the older tires was swapped, one or more may have been damaged during the switch...or stopped working for some other reason.

If they put in a new TPMS, and its not the right transponder freq for your year car, the dash light will come on (Challengers have at least 2 freqs out there for TPMS; a 300-something mhz range for the 08s, a 400-something mhz range for the 09s - 10s).

Think you might have to make that trip back or to the dealer to have it checked out. I'd start with the tire shop since the problem occured right after the new rubber.
 

·
Premium Member
Joined
·
3,546 Posts
Do you have EVIC? If so it will tell you what one it's complaining about. Driving 5 miles should have made it reset but like I said it's not time that changes it like Chevys. It has to be driven.
 

·
Premium Member
Joined
·
2,172 Posts
Discussion Starter #8
I will give it another day or so,,,weather sucks out here so I will have to wait a tads
before taking the car in the rain....
I think they put New TPMS on.
I will take the car for a ride when the rain is gone on Sat
Otherwise Monday I will take the car back........thanks .........JQ
 

·
Premium Member
Joined
·
2,172 Posts
Discussion Starter #10
No Metal stems
Dodge has a Recall on replacement of alltire presure sencers but my
RT is not included so says dodge...
Will take my Car back to tire dealer tomorrow and he says he will checkout the problem tomorrow..........JQ
 

·
Registered
Joined
·
112 Posts
No Metal stems
Dodge has a Recall on replacement of alltire presure sencers but my
RT is not included so says dodge...
Will take my Car back to tire dealer tomorrow and he says he will checkout the problem tomorrow..........JQ
How do you find out which cars are included in the recall? My low pressure light went off today and the tires aren't low at all.
 

·
Premium Member
Joined
·
3,546 Posts
You still should be under warranty and they should fix the light but you can go to Dodges web site with your VIN and it will show you all recalls for your car and if they have been done.
 

·
Registered
Joined
·
112 Posts
You still should be under warranty and they should fix the light but you can go to Dodges web site with your VIN and it will show you all recalls for your car and if they have been done.
Thanks man!
 
1 - 13 of 13 Posts
Top