Dodge Challenger Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Before I say anything,let me make it perfectly clear that I am not bashing Magnuson Superchargers.I love my Maggie!
My question is:Since my S/C installation,I now have a distinct "Ticking Sound"that resonates through my passenger side exhaust.It sounds like it is coming from deep within the S/C but then it sounds like it is coming from the exhaust & then it sounds like it is coming from the top of the motor & then........?
I had the exhaust checked for leaks & the top of the engine also checked for noisy fuel injectors & pcv.No problems found.I also check my oil level weekly.
I heard about the Hemi tick in earlier years but since my car is a 2010,I never had that problem.Until now:scratchhead:
Am I the only one experiencing this???If not,is there a fix or do I have to turn my radio up?:(
 

·
Premium Member
Joined
·
867 Posts
A tick? That's a bad sign with any kind of supercharger. Might want to check the pistons if your sure its not an exhaust leak. Type in tick and supercharger in the search feature and see what pops up, its usually bottom end damage. I will cross fingers for ya.
 

·
Premium Member
Joined
·
2,328 Posts
Naw lot's of them have a tick Mine does some also nothing real serious. I'm racking my brain on what thread we covered this one, can't friggin remember??
 

·
Registered
Joined
·
148 Posts
Discussion Starter #4
Naw lot's of them have a tick Mine does some also nothing real serious. I'm racking my brain on what thread we covered this one, can't friggin remember??
I did come across the Hemi Tick thread but that was for non S/C Hemi's. Mine did not start to tick until I put on the S/C.
Anyone from Magnuson out there?
 

·
Premium Member
Joined
·
4,384 Posts
normally when the ticking stops you hear a loud boom, just messing with you bro.
ask Jessica she seems to know her stuff with the Maggies
 
Joined
·
5,134 Posts
If I'm not mistaken, the 6psi kit comes with Siemens 50lb injectors. You could have a loud one. Does the tick follow engine RPM, or is it exactly two times faster than engine RPM?
 

·
Banned
Joined
·
4,698 Posts
I've got a fair amount of "ticking", Tony, but I think the forged block is noisier than the stocker. Having said that, the stocker HEMI was about as noisy an engine as I've owned given it was relatively new.

HemiSam
 

·
Registered
Joined
·
30 Posts
The tick is from the motor "normal". Although it has been explained several different ways. It is just something that these Hemi's are notorious for. My motor ticked before and after the Maggie install. I assure you it isn't Maggie related.
 

·
Banned
Joined
·
4,131 Posts
hemi's have loud lifters and injectors. 5.7's have a engine cover with insulation that blocks the noise stock. you have removed all that and now hear the noise. there is always the fear of detonating the motor and getting the "broke piston tick"
 

·
Registered
Joined
·
736 Posts
I can say this. I hear EXACTLY the same thing. I was under the car while it was on a lift, and I hear it right in the passenger side muffler. No leak found, but I am 100% sure it is right at the Muffler. It is definitely louder when I first start the car too. I am anal about sounds too.

I can say this though. May car had a sound when you just idled, hit the brake, idled, hit the break. Sound was coming from the rear of the car. Well after 4 days, they figured out it was the bushings in the rear somewhere. To change them, they had to drop some of my exhaust. I can say I did not notice this sound before that. I have Flowmasters with the suitcases removed from the rear.

I am about to buy a new muffler. I would of have noticed this before immediately. Is yours worse when you first start the car for the day (totally cold)?
 

·
Premium Member
Joined
·
659 Posts
Originally Posted by Bonez
Hmmmm, I too have the old "Hemi tick". Didn't have it before the Maggie. It really sounds louder inside the car than it does outside though. Noticed it on first start up after the install. Sounds like it's coming from the passenger side. Exhaust hasn't been touched. I haven't got around to checking it out yet.

Thats it Bonez!...... What you described is exactly what I am dealing with. Looks like it's the nature of the beast this ticking sound. Great post... it put me at ease over this knowing it's not my engine. .... From post #15....Maggie install complete in 15 hrs.

My engine had less than 3000 miles and had never seen 6000 rpm before install. So I can say without any doubt at all that ticking sound was a transplant... As far as that hemi tick...... A solid lifter cam is going to be loud in most applications. That was put rest in 1970 when the 426 went hydraulic.

HOT ROD ON
 

·
Registered
Joined
·
736 Posts
My tick is from directly under the rear passenger seat. Even the Dodge dealer could not figure it out. When we were right on top of it, we know for sure it was coming from that muffler, but no leak was found. Sounds like a tick insider the muffler.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #14
Thanks for Feedback

It is obvious that I am not alone.So if our Hemi's did not "Tick" like this before the S/C then it must be S/C related,no?:scratchhead:Magnuson are you out there?
BTW,I have the injectors that came with the S/C(50lbs).
 

·
Banned
Joined
·
7,566 Posts
I think some of you guys may be a bit paranoid. Mine makes all kinds of sounds, but you gotta expect that from a hot rod.

I don't even notice them anymore. It's just a mechanical symphony to me.
 

·
Registered
Joined
·
297 Posts
I've got nothing... except that there isn't anything touched under the backseat during an install that would make a ticking noise.

We have not heard this one in-house, so we would need more to go off of.
 

·
Registered
Joined
·
736 Posts
I've got nothing... except that there isn't anything touched under the backseat during an install that would make a ticking noise.

We have not heard this one in-house, so we would need more to go off of.
I definitely do not think it is Maggie related. But I have the exact same sound in the same place as described in this thread.
 

·
Registered
Joined
·
688 Posts
I have tried to trace it down and the closest I can come is that it seems to be coming from under the car. It is loudest just before the passenger side rear tire. This happened on the first start up after the Maggie install. I agree, nothing in the install was anywhere near that area of the car. I know for a fact the ticking was not there before the Maggie install because I thought to myself how lucky I was, not having that "hemi tick". I think I remember someone saying something about the fuel pump making that sound, but I really don't know. Perhaps it could be that the fuel pump is working harder than normal with the bigger injectors. It is strange that this is happening on several different Maggie installs. Mine was the 6 psi system on a bone stock 6.1.
 
1 - 18 of 18 Posts
Top