Dodge Challenger Forum banner
1 - 5 of 5 Posts

·
Registered
'13 Dodge Challenger SXT
Joined
·
40 Posts
Discussion Starter · #1 ·
Good morning all,
I've had a Spectre CAI on my SXT for about a year now, and after getting some work done on my car, the "L" bracket that connects the tube to the inner fender is just gone. No idea how! I know it's for stability, but would it pose a risk in any way? Spectre estimate almost three months for a replacement part. Thanks!
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
28,086 Posts
I think you'd be ok, just check the connection to the throttle body every so often to make sure it's not working it's way loose. That's a pretty long pipe to not be anchored somewhere
1013012

A Guy
 
  • Like
Reactions: Phobos

·
Registered
'13 Dodge Challenger SXT
Joined
·
40 Posts
Discussion Starter · #3 ·
I think you'd be ok, just check the connection to the throttle body every so often to make sure it's not working it's way loose. That's a pretty long pipe to not be anchored somewhere
View attachment 1013012
A Guy
You're probably right. I'll keep an eye on it, I appreciate the reply! Definitely a little worrisome.
Our engine bays look nearly identical, I love it!!
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
28,086 Posts
Lol, that's a picture from the web, here's my engine bay


A Guy
 
  • Like
Reactions: Phobos
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top